aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/boards/FREESCALE_FREEDOM_K20D50M
diff options
context:
space:
mode:
Diffstat (limited to 'os/hal/boards/FREESCALE_FREEDOM_K20D50M')
-rw-r--r--os/hal/boards/FREESCALE_FREEDOM_K20D50M/board.c2
-rw-r--r--os/hal/boards/FREESCALE_FREEDOM_K20D50M/board.h18
-rw-r--r--os/hal/boards/FREESCALE_FREEDOM_K20D50M/board.mk4
3 files changed, 21 insertions, 3 deletions
diff --git a/os/hal/boards/FREESCALE_FREEDOM_K20D50M/board.c b/os/hal/boards/FREESCALE_FREEDOM_K20D50M/board.c
index b803d1f..ee86d96 100644
--- a/os/hal/boards/FREESCALE_FREEDOM_K20D50M/board.c
+++ b/os/hal/boards/FREESCALE_FREEDOM_K20D50M/board.c
@@ -116,7 +116,7 @@ const PALConfig pal_default_config =
*/
void __early_init(void) {
- mk20d50_clock_init();
+ k20x_clock_init();
}
/**
diff --git a/os/hal/boards/FREESCALE_FREEDOM_K20D50M/board.h b/os/hal/boards/FREESCALE_FREEDOM_K20D50M/board.h
index 41ce877..cf41495 100644
--- a/os/hal/boards/FREESCALE_FREEDOM_K20D50M/board.h
+++ b/os/hal/boards/FREESCALE_FREEDOM_K20D50M/board.h
@@ -27,6 +27,24 @@
#define BOARD_FREESCALE_FREEDOM_K20D50M
#define BOARD_NAME "Freescale Freedom K20D50M"
+/* External 8 MHz crystal. */
+#define KINETIS_XTAL_FREQUENCY 8000000UL
+
+/*
+ * MCU type
+ */
+#define K20x5
+
+/*
+ * Onboard features.
+ */
+#define GPIO_LED_RED IOPORT3
+#define PIN_LED_RED 3
+#define GPIO_LED_GREEN IOPORT4
+#define PIN_LED_GREEN 4
+#define GPIO_LED_BLUE IOPORT1
+#define PIN_LED_BLUE 2
+
#if !defined(_FROM_ASM_)
#ifdef __cplusplus
extern "C" {
diff --git a/os/hal/boards/FREESCALE_FREEDOM_K20D50M/board.mk b/os/hal/boards/FREESCALE_FREEDOM_K20D50M/board.mk
index e09d821..f74d306 100644
--- a/os/hal/boards/FREESCALE_FREEDOM_K20D50M/board.mk
+++ b/os/hal/boards/FREESCALE_FREEDOM_K20D50M/board.mk
@@ -1,5 +1,5 @@
# List of all the board related files.
-BOARDSRC = ${CHIBIOS}/os/hal/boards/FREESCALE_FREEDOM_K20D50M/board.c
+BOARDSRC = ${CHIBIOS_CONTRIB}/os/hal/boards/FREESCALE_FREEDOM_K20D50M/board.c
# Required include directories
-BOARDINC = ${CHIBIOS}/os/hal/boards/FREESCALE_FREEDOM_K20D50M
+BOARDINC = ${CHIBIOS_CONTRIB}/os/hal/boards/FREESCALE_FREEDOM_K20D50M