aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal
diff options
context:
space:
mode:
Diffstat (limited to 'os/hal')
-rw-r--r--os/hal/boards/NRF51-DK/board.c80
-rw-r--r--os/hal/boards/NRF51-DK/board.h57
-rw-r--r--os/hal/boards/NRF51-DK/board.mk5
-rw-r--r--os/hal/ports/NRF51/NRF51822/serial_lld.c55
-rw-r--r--os/hal/ports/NRF51/NRF51822/serial_lld.h14
5 files changed, 200 insertions, 11 deletions
diff --git a/os/hal/boards/NRF51-DK/board.c b/os/hal/boards/NRF51-DK/board.c
new file mode 100644
index 0000000..e976e56
--- /dev/null
+++ b/os/hal/boards/NRF51-DK/board.c
@@ -0,0 +1,80 @@
+/*
+ Copyright (C) 2015 Fabio Utzig
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+*/
+
+#include "hal.h"
+
+#if HAL_USE_PAL || defined(__DOXYGEN__)
+/**
+ * @brief PAL setup.
+ * @details Digital I/O ports static configuration as defined in @p board.h.
+ * This variable is used by the HAL when initializing the PAL driver.
+ */
+const PALConfig pal_default_config =
+{
+ .pads = {
+ PAL_MODE_UNCONNECTED, /* P0.0 */
+ PAL_MODE_UNCONNECTED, /* P0.1 */
+ PAL_MODE_UNCONNECTED, /* P0.2 */
+ PAL_MODE_UNCONNECTED, /* P0.3 */
+ PAL_MODE_UNCONNECTED, /* P0.4 */
+ PAL_MODE_UNCONNECTED, /* P0.5 */
+ PAL_MODE_UNCONNECTED, /* P0.6 */
+ PAL_MODE_OUTPUT_OPENDRAIN, /* P0.7 : SCL */
+ PAL_MODE_OUTPUT_PUSHPULL, /* P0.8 : UART_RTS */
+ PAL_MODE_OUTPUT_PUSHPULL, /* P0.9 : UART_TX */
+ PAL_MODE_INPUT_PULLUP, /* P0.10: UART_CTS */
+ PAL_MODE_INPUT_PULLUP, /* P0.11: UART_RX */
+ PAL_MODE_UNCONNECTED, /* P0.12 */
+ PAL_MODE_UNCONNECTED, /* P0.13 */
+ PAL_MODE_UNCONNECTED, /* P0.14 */
+ PAL_MODE_UNCONNECTED, /* P0.15 */
+ PAL_MODE_UNCONNECTED, /* P0.16 */
+ PAL_MODE_INPUT_PULLUP, /* P0.17: BTN1 */
+ PAL_MODE_INPUT_PULLUP, /* P0.18: BTN2 */
+ PAL_MODE_INPUT_PULLUP, /* P0.19: BTN3 */
+ PAL_MODE_INPUT_PULLUP, /* P0.20: BTN4 */
+ PAL_MODE_OUTPUT_PUSHPULL, /* P0.21: LED1 */
+ PAL_MODE_OUTPUT_PUSHPULL, /* P0.22: LED2 */
+ PAL_MODE_OUTPUT_PUSHPULL, /* P0.23: LED3 */
+ PAL_MODE_OUTPUT_PUSHPULL, /* P0.24: LED4 | SPI_SEL */
+ PAL_MODE_OUTPUT_PUSHPULL, /* P0.25: SPI_MOSI */
+ PAL_MODE_UNCONNECTED, /* P0.26: XTAL (32MHz) */
+ PAL_MODE_UNCONNECTED, /* P0.27: XTAL (32MHz) */
+ PAL_MODE_INPUT_PULLUP, /* P0.28: SPI_MISO */
+ PAL_MODE_OUTPUT_PUSHPULL, /* P0.29: SPI_SCK */
+ PAL_MODE_OUTPUT_OPENDRAIN, /* P0.30: SDA */
+ PAL_MODE_UNCONNECTED, /* P0.31 */
+ },
+};
+#endif
+
+/**
+ * @brief Early initialization code.
+ * @details This initialization is performed just after reset before BSS and
+ * DATA segments initialization.
+ */
+void __early_init(void)
+{
+}
+
+/**
+ * @brief Late initialization code.
+ * @note This initialization is performed after BSS and DATA segments
+ * initialization and before invoking the main() function.
+ */
+void boardInit(void)
+{
+}
diff --git a/os/hal/boards/NRF51-DK/board.h b/os/hal/boards/NRF51-DK/board.h
new file mode 100644
index 0000000..5e0c738
--- /dev/null
+++ b/os/hal/boards/NRF51-DK/board.h
@@ -0,0 +1,57 @@
+/*
+ Copyright (C) 2015 Fabio Utzig
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+*/
+
+#ifndef _BOARD_H_
+#define _BOARD_H_
+
+/* Board identifier. */
+#define BOARD_NRF51_DK
+#define BOARD_NAME "nRF51 DK"
+
+/* Board oscillators-related settings. */
+#define XTAL_VALUE 16000000
+
+/* GPIO pins. */
+#define BTN1 17
+#define BTN2 18
+#define BTN3 19
+#define BTN4 20
+#define LED1 21
+#define LED2 22
+#define LED3 23
+#define LED4 24
+#define UART_RTS 8
+#define UART_TX 9
+#define UART_CTS 10
+#define UART_RX 11
+#define SPI_SCK 29
+#define SPI_MOSI 25
+#define SPI_MISO 28
+#define SPI_SS 24
+#define I2C_SCL 7
+#define I2C_SDA 30
+
+#if !defined(_FROM_ASM_)
+#ifdef __cplusplus
+extern "C" {
+#endif
+ void boardInit(void);
+#ifdef __cplusplus
+}
+#endif
+#endif /* _FROM_ASM_ */
+
+#endif /* _BOARD_H_ */
diff --git a/os/hal/boards/NRF51-DK/board.mk b/os/hal/boards/NRF51-DK/board.mk
new file mode 100644
index 0000000..4d20da3
--- /dev/null
+++ b/os/hal/boards/NRF51-DK/board.mk
@@ -0,0 +1,5 @@
+# List of all the board related files.
+BOARDSRC = ${CHIBIOS_CONTRIB}/os/hal/boards/NRF51-DK/board.c
+
+# Required include directories
+BOARDINC = ${CHIBIOS_CONTRIB}/os/hal/boards/NRF51-DK
diff --git a/os/hal/ports/NRF51/NRF51822/serial_lld.c b/os/hal/ports/NRF51/NRF51822/serial_lld.c
index bc4a9b6..550a070 100644
--- a/os/hal/ports/NRF51/NRF51822/serial_lld.c
+++ b/os/hal/ports/NRF51/NRF51822/serial_lld.c
@@ -49,9 +49,13 @@ SerialDriver SD1;
* @brief Driver default configuration.
*/
static const SerialConfig default_config = {
- .speed = 38400,
- .tx_pad = NRF51_SERIAL_PAD_DISCONNECTED,
- .rx_pad = NRF51_SERIAL_PAD_DISCONNECTED,
+ .speed = 38400,
+ .tx_pad = NRF51_SERIAL_PAD_DISCONNECTED,
+ .rx_pad = NRF51_SERIAL_PAD_DISCONNECTED,
+#if (NRF51_SERIAL_USE_HWFLOWCTRL == TRUE)
+ .rts_pad = NRF51_SERIAL_PAD_DISCONNECTED,
+ .cts_pad = NRF51_SERIAL_PAD_DISCONNECTED,
+#endif
};
/*===========================================================================*/
@@ -68,7 +72,6 @@ static const SerialConfig default_config = {
*/
static void configure_uart(const SerialConfig *config)
{
- /* TODO: Add support for CTS/RTS! */
uint32_t speed = UART_BAUDRATE_BAUDRATE_Baud250000;
switch (config->speed) {
@@ -91,26 +94,56 @@ static void configure_uart(const SerialConfig *config)
default: osalDbgAssert(0, "invalid baudrate"); break;
};
- /* Configure PINs */
+ /* Configure PINs mode */
if (config->tx_pad != NRF51_SERIAL_PAD_DISCONNECTED) {
palSetPadMode(IOPORT1, config->tx_pad, PAL_MODE_OUTPUT_PUSHPULL);
- NRF_UART0->PSELTXD = config->tx_pad;
}
if (config->rx_pad != NRF51_SERIAL_PAD_DISCONNECTED) {
palSetPadMode(IOPORT1, config->rx_pad, PAL_MODE_INPUT);
- NRF_UART0->PSELRXD = config->rx_pad;
}
+#if (NRF51_SERIAL_USE_HWFLOWCTRL == TRUE)
+ if (config->rts_pad != NRF51_SERIAL_PAD_DISCONNECTED) {
+ palSetPadMode(IOPORT1, config->rts_pad, PAL_MODE_OUTPUT_PUSHPULL);
+ }
+ if (config->cts_pad != NRF51_SERIAL_PAD_DISCONNECTED) {
+ palSetPadMode(IOPORT1, config->cts_pad, PAL_MODE_INPUT);
+ }
+#endif
+
+ /* Select PINs used by UART */
+ NRF_UART0->PSELTXD = config->tx_pad;
+ NRF_UART0->PSELRXD = config->rx_pad;
+#if (NRF51_SERIAL_USE_HWFLOWCTRL == TRUE)
+ NRF_UART0->PSELRTS = config->rts_pad;
+ NRF_UART0->PSELCTS = config->cts_pad;
+#else
+ NRF_UART0->PSELRTS = NRF51_SERIAL_PAD_DISCONNECTED;
+ NRF_UART0->PSELCTS = NRF51_SERIAL_PAD_DISCONNECTED;
+#endif
+ /* Set baud rate */
NRF_UART0->BAUDRATE = speed;
+
+ /* Set config */
NRF_UART0->CONFIG = (UART_CONFIG_PARITY_Excluded << UART_CONFIG_PARITY_Pos);
+
+ /* Adjust flow control */
+#if (NRF51_SERIAL_USE_HWFLOWCTRL == TRUE)
+ if ((config->rts_pad < TOTAL_GPIO_PADS) ||
+ (config->cts_pad < TOTAL_GPIO_PADS)) {
+ NRF_UART0->CONFIG |= UART_CONFIG_HWFC_Enabled << UART_CONFIG_HWFC_Pos;
+ } else {
+ NRF_UART0->CONFIG &= ~(UART_CONFIG_HWFC_Enabled << UART_CONFIG_HWFC_Pos);
+ }
+#else
+ NRF_UART0->CONFIG &= ~(UART_CONFIG_HWFC_Enabled << UART_CONFIG_HWFC_Pos);
+#endif
+
+ /* Enable UART and clear events */
NRF_UART0->ENABLE = UART_ENABLE_ENABLE_Enabled;
NRF_UART0->EVENTS_RXDRDY = 0;
NRF_UART0->EVENTS_TXDRDY = 0;
- NRF_UART0->CONFIG &= ~(UART_CONFIG_HWFC_Enabled << UART_CONFIG_HWFC_Pos);
-
- NRF_UART0->PSELRTS = NRF51_SERIAL_PAD_DISCONNECTED;
- NRF_UART0->PSELCTS = NRF51_SERIAL_PAD_DISCONNECTED;
if (config->rx_pad != NRF51_SERIAL_PAD_DISCONNECTED) {
while (NRF_UART0->EVENTS_RXDRDY != 0) {
diff --git a/os/hal/ports/NRF51/NRF51822/serial_lld.h b/os/hal/ports/NRF51/NRF51822/serial_lld.h
index 8da3998..5fc5e87 100644
--- a/os/hal/ports/NRF51/NRF51822/serial_lld.h
+++ b/os/hal/ports/NRF51/NRF51822/serial_lld.h
@@ -40,6 +40,16 @@
* @{
*/
/**
+ * @brief SD flow control enable switch.
+ * @details If set to @p TRUE the support for hardware flow control
+ * is included.
+ * @note The default is @p FALSE.
+ */
+#if !defined(NRF51_SERIAL_USE_HWFLOWCTRL) || defined(__DOXYGEN__)
+#define NRF51_SERIAL_USE_HWFLOWCTRL FALSE
+#endif
+
+/**
* @brief SD1 driver enable switch.
* @details If set to @p TRUE the support for SD1 is included.
* @note The default is @p FALSE.
@@ -85,6 +95,10 @@ typedef struct {
/* End of the mandatory fields.*/
uint32_t tx_pad;
uint32_t rx_pad;
+#if (NRF51_SERIAL_USE_HWFLOWCTRL == TRUE)
+ uint32_t rts_pad;
+ uint32_t cts_pad;
+#endif
} SerialConfig;
/**