aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/TIVA/TM4C123x/EXT
diff options
context:
space:
mode:
Diffstat (limited to 'testhal/TIVA/TM4C123x/EXT')
-rw-r--r--testhal/TIVA/TM4C123x/EXT/.project11
-rw-r--r--testhal/TIVA/TM4C123x/EXT/Makefile6
-rw-r--r--testhal/TIVA/TM4C123x/EXT/chconf.h1
-rw-r--r--testhal/TIVA/TM4C123x/EXT/debug/OpenOCD on ICDI (prompts for .cfg target configuration).launch10
-rw-r--r--testhal/TIVA/TM4C123x/EXT/main.c14
-rw-r--r--testhal/TIVA/TM4C123x/EXT/mcuconf.h8
6 files changed, 21 insertions, 29 deletions
diff --git a/testhal/TIVA/TM4C123x/EXT/.project b/testhal/TIVA/TM4C123x/EXT/.project
index 79bd112..c1e2c0f 100644
--- a/testhal/TIVA/TM4C123x/EXT/.project
+++ b/testhal/TIVA/TM4C123x/EXT/.project
@@ -79,22 +79,17 @@
<link>
<name>board</name>
<type>2</type>
- <locationURI>CHIBIOS3/community/os/hal/boards/TI_TM4C123G_LAUNCHPAD</locationURI>
+ <locationURI>PARENT-1-CHIBIOS/ChibiOS-Contrib/os/hal/boards/TI_TM4C123G_LAUNCHPAD</locationURI>
</link>
<link>
<name>community_os</name>
<type>2</type>
- <locationURI>CHIBIOS3/community/os</locationURI>
+ <locationURI>PARENT-1-CHIBIOS/ChibiOS-Contrib/os</locationURI>
</link>
<link>
<name>os</name>
<type>2</type>
- <locationURI>CHIBIOS3/os</locationURI>
- </link>
- <link>
- <name>test</name>
- <type>2</type>
- <locationURI>CHIBIOS3/test</locationURI>
+ <locationURI>CHIBIOS/os</locationURI>
</link>
</linkedResources>
<variableList>
diff --git a/testhal/TIVA/TM4C123x/EXT/Makefile b/testhal/TIVA/TM4C123x/EXT/Makefile
index f587083..f2833ec 100644
--- a/testhal/TIVA/TM4C123x/EXT/Makefile
+++ b/testhal/TIVA/TM4C123x/EXT/Makefile
@@ -43,6 +43,12 @@ ifeq ($(USE_VERBOSE_COMPILE),)
USE_VERBOSE_COMPILE = no
endif
+# If enabled, this option makes the build process faster by not compiling
+# modules not used in the current configuration.
+ifeq ($(USE_SMART_BUILD),)
+ USE_SMART_BUILD = yes
+endif
+
#
# Build global options
##############################################################################
diff --git a/testhal/TIVA/TM4C123x/EXT/chconf.h b/testhal/TIVA/TM4C123x/EXT/chconf.h
index dd6722a..c56df3c 100644
--- a/testhal/TIVA/TM4C123x/EXT/chconf.h
+++ b/testhal/TIVA/TM4C123x/EXT/chconf.h
@@ -18,6 +18,7 @@
#define _CHCONF_H_
#define _CHIBIOS_RT_CONF_
+#define _CHIBIOS_RT_CONF_VER_5_0_
/*===========================================================================*/
/**
diff --git a/testhal/TIVA/TM4C123x/EXT/debug/OpenOCD on ICDI (prompts for .cfg target configuration).launch b/testhal/TIVA/TM4C123x/EXT/debug/OpenOCD on ICDI (prompts for .cfg target configuration).launch
deleted file mode 100644
index 8772f9c..0000000
--- a/testhal/TIVA/TM4C123x/EXT/debug/OpenOCD on ICDI (prompts for .cfg target configuration).launch
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<launchConfiguration type="org.eclipse.ui.externaltools.ProgramLaunchConfigurationType">
-<listAttribute key="org.eclipse.debug.ui.favoriteGroups">
-<listEntry value="org.eclipse.ui.externaltools.launchGroup"/>
-</listAttribute>
-<stringAttribute key="org.eclipse.ui.externaltools.ATTR_LAUNCH_CONFIGURATION_BUILD_SCOPE" value="${none}"/>
-<stringAttribute key="org.eclipse.ui.externaltools.ATTR_LOCATION" value="${eclipse_home}\..\tools\openocd\bin\openocd.exe"/>
-<stringAttribute key="org.eclipse.ui.externaltools.ATTR_TOOL_ARGUMENTS" value="-c &quot;telnet_port 4444&quot; -f &quot;interface/ti-icdi.cfg&quot; -f &quot;${file_prompt}&quot;"/>
-<stringAttribute key="org.eclipse.ui.externaltools.ATTR_WORKING_DIRECTORY" value="${eclipse_home}\..\tools\openocd\bin\"/>
-</launchConfiguration>
diff --git a/testhal/TIVA/TM4C123x/EXT/main.c b/testhal/TIVA/TM4C123x/EXT/main.c
index 4370794..2326375 100644
--- a/testhal/TIVA/TM4C123x/EXT/main.c
+++ b/testhal/TIVA/TM4C123x/EXT/main.c
@@ -1,5 +1,5 @@
/*
- Copyright (C) 2014..2016 Marco Veeneman
+ Copyright (C) 2014..2017 Marco Veeneman
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
@@ -22,7 +22,7 @@ static void extcb1(EXTDriver *extp, expchannel_t channel)
(void)extp;
(void)channel;
- palTogglePad(GPIOF, GPIOF_LED_RED);
+ palToggleLine(LINE_LED_RED);
}
static void extcb2(EXTDriver *extp, expchannel_t channel)
@@ -30,7 +30,7 @@ static void extcb2(EXTDriver *extp, expchannel_t channel)
(void)extp;
(void)channel;
- palTogglePad(GPIOF, GPIOF_LED_GREEN);
+ palToggleLine(LINE_LED_GREEN);
}
static const EXTConfig extcfg =
@@ -108,10 +108,10 @@ int main(void)
halInit();
chSysInit();
- palSetPadMode(GPIOF, GPIOF_LED_RED, PAL_MODE_OUTPUT_PUSHPULL);
- palSetPadMode(GPIOF, GPIOF_LED_GREEN, PAL_MODE_OUTPUT_PUSHPULL);
- palSetPadMode(GPIOF, GPIOF_SW1, PAL_MODE_INPUT_PULLUP);
- palSetPadMode(GPIOF, GPIOF_SW2, PAL_MODE_INPUT_PULLUP);
+ palSetLineMode(LINE_LED_RED, PAL_MODE_OUTPUT_PUSHPULL);
+ palSetLineMode(LINE_LED_GREEN, PAL_MODE_OUTPUT_PUSHPULL);
+ palSetLineMode(LINE_SW1, PAL_MODE_INPUT_PULLUP);
+ palSetLineMode(LINE_SW2, PAL_MODE_INPUT_PULLUP);
extStart(&EXTD1, &extcfg);
diff --git a/testhal/TIVA/TM4C123x/EXT/mcuconf.h b/testhal/TIVA/TM4C123x/EXT/mcuconf.h
index 74a4da3..e936c02 100644
--- a/testhal/TIVA/TM4C123x/EXT/mcuconf.h
+++ b/testhal/TIVA/TM4C123x/EXT/mcuconf.h
@@ -1,5 +1,5 @@
/*
- Copyright (C) 2014..2016 Marco Veeneman
+ Copyright (C) 2014..2017 Marco Veeneman
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
@@ -30,15 +30,15 @@
/*
* HAL driver system settings.
*/
-#define TIVA_OSCSRC TIVA_RCC2_OSCSRC2_MOSC
+#define TIVA_OSCSRC SYSCTL_RCC2_OSCSRC2_MO
#define TIVA_MOSC_ENABLE TRUE
#define TIVA_DIV400_VALUE 1
#define TIVA_SYSDIV_VALUE 2
#define TIVA_USESYSDIV_ENABLE FALSE
#define TIVA_SYSDIV2LSB_ENABLE FALSE
#define TIVA_BYPASS_VALUE 0
-#define TIVA_PWM_FIELDS (TIVA_RCC_USEPWMDIV | \
- TIVA_RCC_PWMDIV_8)
+#define TIVA_PWM_FIELDS (SYSCTL_RCC_USEPWMDIV | \
+ SYSCTL_RCC_PWMDIV_8)
/*
* GPIO driver system settings.