aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/TIVA/TM4C123x/WDG
diff options
context:
space:
mode:
Diffstat (limited to 'testhal/TIVA/TM4C123x/WDG')
-rw-r--r--testhal/TIVA/TM4C123x/WDG/.project2
-rw-r--r--testhal/TIVA/TM4C123x/WDG/Makefile8
2 files changed, 8 insertions, 2 deletions
diff --git a/testhal/TIVA/TM4C123x/WDG/.project b/testhal/TIVA/TM4C123x/WDG/.project
index 1c2bc3f..8f385fb 100644
--- a/testhal/TIVA/TM4C123x/WDG/.project
+++ b/testhal/TIVA/TM4C123x/WDG/.project
@@ -79,7 +79,7 @@
<link>
<name>board</name>
<type>2</type>
- <locationURI>CHIBIOS/community/os/hal/boards/TI_TM4C123G_LAUNCHPAD</locationURI>
+ <locationURI>PARENT-1-CHIBIOS/ChibiOS-Contrib/os/hal/boards/TI_TM4C123G_LAUNCHPAD</locationURI>
</link>
<link>
<name>community_os</name>
diff --git a/testhal/TIVA/TM4C123x/WDG/Makefile b/testhal/TIVA/TM4C123x/WDG/Makefile
index 5ae01c9..f2833ec 100644
--- a/testhal/TIVA/TM4C123x/WDG/Makefile
+++ b/testhal/TIVA/TM4C123x/WDG/Makefile
@@ -5,7 +5,7 @@
# Compiler options here.
ifeq ($(USE_OPT),)
- USE_OPT = -O0 -ggdb -fomit-frame-pointer -falign-functions=16
+ USE_OPT = -O2 -ggdb -fomit-frame-pointer -falign-functions=16
endif
# C specific options here (added to USE_OPT).
@@ -43,6 +43,12 @@ ifeq ($(USE_VERBOSE_COMPILE),)
USE_VERBOSE_COMPILE = no
endif
+# If enabled, this option makes the build process faster by not compiling
+# modules not used in the current configuration.
+ifeq ($(USE_SMART_BUILD),)
+ USE_SMART_BUILD = yes
+endif
+
#
# Build global options
##############################################################################