aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--os/hal/platforms/MSP430/platform.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/os/hal/platforms/MSP430/platform.mk b/os/hal/platforms/MSP430/platform.mk
new file mode 100644
index 000000000..d0175c1df
--- /dev/null
+++ b/os/hal/platforms/MSP430/platform.mk
@@ -0,0 +1,7 @@
+# List of all the MSP430 platform files.
+PLATFORMSRC = ${CHIBIOS}/os/hal/platforms/MSP430/hal_lld.c \
+ ${CHIBIOS}/os/hal/platforms/MSP430/pal_lld.c \
+ ${CHIBIOS}/os/hal/platforms/MSP430/serial_lld.c
+
+# Required include directories
+PLATFORMINC = ${CHIBIOS}/os/hal/platforms/MSP430