diff options
-rwxr-xr-x | testhal/ATSAMA5D2/SERIAL/Makefile | 5 |
1 files changed, 3 insertions, 2 deletions
diff --git a/testhal/ATSAMA5D2/SERIAL/Makefile b/testhal/ATSAMA5D2/SERIAL/Makefile index fa4cd188f..41ebc4ffd 100755 --- a/testhal/ATSAMA5D2/SERIAL/Makefile +++ b/testhal/ATSAMA5D2/SERIAL/Makefile @@ -122,6 +122,7 @@ include $(CHIBIOS)/os/hal/osal/rt/osal.mk include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/common/ports/ARMCAx-TZ/compilers/GCC/mk/port_generic.mk
# Other files (optional).
+include $(CHIBIOS)/os/hal/lib/streams/streams.mk
#include $(CHIBIOS)/test/lib/test.mk
#include $(CHIBIOS)/test/rt/rt_test.mk
#include $(CHIBIOS)/test/oslib/oslib_test.mk
@@ -141,7 +142,7 @@ CSRC = $(STARTUPSRC) \ $(PLATFORMSRC) \
$(BOARDSRC) \
$(TESTSRC) \
- $(CHIBIOS)/os/hal/lib/streams/chprintf.c \
+ $(STREAMSSRC) \
main.c
# C++ sources that can be compiled in ARM or THUMB mode depending on the global
@@ -175,7 +176,7 @@ ASMXSRC = $(STARTUPASM) $(PORTASM) $(OSALASM) INCDIR = $(CHIBIOS)/os/license \
$(STARTUPINC) $(KERNINC) $(PORTINC) $(OSALINC) \
$(HALINC) $(PLATFORMINC) $(BOARDINC) $(TESTINC) \
- $(CHIBIOS)/os/hal/lib/streams $(CHIBIOS)/os/various
+ $(STREAMSINC) $(CHIBIOS)/os/various
#
# Project, sources and paths
|