aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--demos/Posix-GCC/Makefile1
-rw-r--r--demos/Win32-MinGW/Makefile1
-rw-r--r--readme.txt2
3 files changed, 4 insertions, 0 deletions
diff --git a/demos/Posix-GCC/Makefile b/demos/Posix-GCC/Makefile
index 5d77f6a8e..c35a5f7df 100644
--- a/demos/Posix-GCC/Makefile
+++ b/demos/Posix-GCC/Makefile
@@ -72,6 +72,7 @@ SRC = ${PORTSRC} \
${PLATFORMSRC} \
$(BOARDSRC) \
${CHIBIOS}/os/various/shell.c \
+ ${CHIBIOS}/os/various/memstreams.c \
${CHIBIOS}/os/various/chprintf.c \
main.c
diff --git a/demos/Win32-MinGW/Makefile b/demos/Win32-MinGW/Makefile
index 1b77c241c..8b489535e 100644
--- a/demos/Win32-MinGW/Makefile
+++ b/demos/Win32-MinGW/Makefile
@@ -72,6 +72,7 @@ SRC = ${PORTSRC} \
${PLATFORMSRC} \
$(BOARDSRC) \
${CHIBIOS}/os/various/shell.c \
+ ${CHIBIOS}/os/various/memstreams.c \
${CHIBIOS}/os/various/chprintf.c \
main.c
diff --git a/readme.txt b/readme.txt
index 04a9a1340..2d76a7bec 100644
--- a/readme.txt
+++ b/readme.txt
@@ -89,6 +89,8 @@
*****************************************************************************
*** 2.7.0 ***
+- FIX: Fixed memstreams.c missing from simulator makefiles (bug #454)
+ (backported to 2.6.3).
- FIX: Fixed chprintf() does not compile in strict C90 mode (bug #453)
(backported to 2.6.3).
- FIX: Fixed wrong vector names for STM32Lxx (bug #451)(backported