aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--os/hal/platforms/STM32L1xx/platform.mk20
1 files changed, 16 insertions, 4 deletions
diff --git a/os/hal/platforms/STM32L1xx/platform.mk b/os/hal/platforms/STM32L1xx/platform.mk
index 5b46c7389..6d1bb61c4 100644
--- a/os/hal/platforms/STM32L1xx/platform.mk
+++ b/os/hal/platforms/STM32L1xx/platform.mk
@@ -1,7 +1,19 @@
-# List of all the STM32 platform files.
+# List of all the STM32L1xx platform files.
PLATFORMSRC = ${CHIBIOS}/os/hal/platforms/STM32L1xx/hal_lld.c \
- ${CHIBIOS}/os/hal/platforms/STM32L1xx/pal_lld.c \
- ${CHIBIOS}/os/hal/platforms/STM32L1xx/stm32_dma.c
+ ${CHIBIOS}/os/hal/platforms/STM32/gpt_lld.c \
+ ${CHIBIOS}/os/hal/platforms/STM32/icu_lld.c \
+ ${CHIBIOS}/os/hal/platforms/STM32/pwm_lld.c \
+ ${CHIBIOS}/os/hal/platforms/STM32/serial_lld.c \
+ ${CHIBIOS}/os/hal/platforms/STM32/GPIOv2/pal_lld.c \
+ ${CHIBIOS}/os/hal/platforms/STM32/DMAv1/adc_lld.c \
+ ${CHIBIOS}/os/hal/platforms/STM32/DMAv1/spi_lld.c \
+ ${CHIBIOS}/os/hal/platforms/STM32/DMAv1/uart_lld.c \
+ ${CHIBIOS}/os/hal/platforms/STM32/DMAv1/stm32_dma.c \
+ ${CHIBIOS}/os/hal/platforms/STM32/USBv1/usb_lld.c
# Required include directories
-PLATFORMINC = ${CHIBIOS}/os/hal/platforms/STM32L1xx
+PLATFORMINC = ${CHIBIOS}/os/hal/platforms/STM32L1xx \
+ ${CHIBIOS}/os/hal/platforms/STM32 \
+ ${CHIBIOS}/os/hal/platforms/STM32/GPIOv2 \
+ ${CHIBIOS}/os/hal/platforms/STM32/DMAv1 \
+ ${CHIBIOS}/os/hal/platforms/STM32/USBv1