aboutsummaryrefslogtreecommitdiffstats
path: root/boards/ARDUINO
diff options
context:
space:
mode:
Diffstat (limited to 'boards/ARDUINO')
-rw-r--r--boards/ARDUINO/board.c73
-rw-r--r--boards/ARDUINO/board.h86
-rw-r--r--boards/ARDUINO/board.mk5
3 files changed, 0 insertions, 164 deletions
diff --git a/boards/ARDUINO/board.c b/boards/ARDUINO/board.c
deleted file mode 100644
index 1cb0f1adc..000000000
--- a/boards/ARDUINO/board.c
+++ /dev/null
@@ -1,73 +0,0 @@
-/*
- ChibiOS/RT - Copyright (C) 2006-2013 Giovanni Di Sirio
-
- Licensed under the Apache License, Version 2.0 (the "License");
- you may not use this file except in compliance with the License.
- You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing, software
- distributed under the License is distributed on an "AS IS" BASIS,
- WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- See the License for the specific language governing permissions and
- limitations under the License.
-*/
-
-#include "ch.h"
-#include "hal.h"
-
-/**
- * @brief PAL setup.
- * @details Digital I/O ports static configuration as defined in @p board.h.
- * This variable is used by the HAL when initializing the PAL driver.
- */
-#if HAL_USE_PAL || defined(__DOXYGEN__)
-const PALConfig pal_default_config =
-{
-#if defined(PORTA)
- {VAL_PORTA, VAL_DDRA},
-#endif
-#if defined(PORTB)
- {VAL_PORTB, VAL_DDRB},
-#endif
-#if defined(PORTC)
- {VAL_PORTC, VAL_DDRC},
-#endif
-#if defined(PORTD)
- {VAL_PORTD, VAL_DDRD},
-#endif
-#if defined(PORTE)
- {VAL_PORTE, VAL_DDRE},
-#endif
-#if defined(PORTF)
- {VAL_PORTF, VAL_DDRF},
-#endif
-#if defined(PORTG)
- {VAL_PORTG, VAL_DDRG},
-#endif
-#if defined(PORTH)
- {VAL_PORTH, VAL_DDRH},
-#endif
-#if defined(PORTJ)
- {VAL_PORTJ, VAL_DDRJ},
-#endif
-#if defined(PORTK)
- {VAL_PORTK, VAL_DDRK},
-#endif
-#if defined(PORTL)
- {VAL_PORTL, VAL_DDRL},
-#endif
-};
-#endif /* HAL_USE_PAL */
-
-/**
- * Board-specific initialization code.
- */
-void boardInit(void) {
- /*
- * External interrupts setup, all disabled initially.
- */
- EICRA = 0x00;
- EIMSK = 0x00;
-}
diff --git a/boards/ARDUINO/board.h b/boards/ARDUINO/board.h
deleted file mode 100644
index 62da0caac..000000000
--- a/boards/ARDUINO/board.h
+++ /dev/null
@@ -1,86 +0,0 @@
-/*
- ChibiOS/RT - Copyright (C) 2006-2013 Giovanni Di Sirio
-
- Licensed under the Apache License, Version 2.0 (the "License");
- you may not use this file except in compliance with the License.
- You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing, software
- distributed under the License is distributed on an "AS IS" BASIS,
- WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- See the License for the specific language governing permissions and
- limitations under the License.
-*/
-
-#ifndef _BOARD_H_
-#define _BOARD_H_
-
-/*
- * Setup for the Arduino Mega board.
- */
-
-/*
- * Board identifier.
- */
-#define BOARD_ARDUINO
-#define BOARD_NAME "Arduino"
-
-/* All inputs with pull-ups */
-#define VAL_DDRA 0x00
-#define VAL_PORTA 0xFF
-
-/* All inputs except PB5 which has a LED connected */
-#define VAL_DDRB 0x20
-#define VAL_PORTB 0xFF
-
-/* All inputs with pull-ups */
-#define VAL_DDRC 0x00
-#define VAL_PORTC 0xFF
-
-/* All inputs with pull-ups */
-#define VAL_DDRD 0x00
-#define VAL_PORTD 0xFF
-
-/* All inputs except PE1 (Serial TX0) */
-#define VAL_DDRE 0x02
-#define VAL_PORTE 0xFF
-
-/* All inputs with pull-ups */
-#define VAL_DDRF 0x00
-#define VAL_PORTF 0xFF
-
-/* All inputs with pull-ups */
-#define VAL_DDRG 0x00
-#define VAL_PORTG 0xFF
-
-/* All inputs with pull-ups */
-#define VAL_DDRH 0x00
-#define VAL_PORTH 0xFF
-
-/* All inputs with pull-ups */
-#define VAL_DDRJ 0x00
-#define VAL_PORTJ 0xFF
-
-/* All inputs with pull-ups */
-#define VAL_DDRK 0x00
-#define VAL_PORTK 0xFF
-
-/* All inputs with pull-ups */
-#define VAL_DDRL 0x00
-#define VAL_PORTL 0xFF
-
-#define PORTB_LED1 5
-
-#if !defined(_FROM_ASM_)
-#ifdef __cplusplus
-extern "C" {
-#endif
- void boardInit(void);
-#ifdef __cplusplus
-}
-#endif
-#endif /* _FROM_ASM_ */
-
-#endif /* _BOARD_H_ */
diff --git a/boards/ARDUINO/board.mk b/boards/ARDUINO/board.mk
deleted file mode 100644
index 1dd55e286..000000000
--- a/boards/ARDUINO/board.mk
+++ /dev/null
@@ -1,5 +0,0 @@
-# List of all the board related files.
-BOARDSRC = ${CHIBIOS}/boards/ARDUINO/board.c
-
-# Required include directories
-BOARDINC = ${CHIBIOS}/boards/ARDUINO