diff options
Diffstat (limited to 'demos/ARM7-AT91SAM7X-UIP-GCC')
-rw-r--r-- | demos/ARM7-AT91SAM7X-UIP-GCC/Makefile | 4 | ||||
-rw-r--r-- | demos/ARM7-AT91SAM7X-UIP-GCC/main.c | 4 | ||||
-rw-r--r-- | demos/ARM7-AT91SAM7X-UIP-GCC/web/webthread.c | 5 |
3 files changed, 11 insertions, 2 deletions
diff --git a/demos/ARM7-AT91SAM7X-UIP-GCC/Makefile b/demos/ARM7-AT91SAM7X-UIP-GCC/Makefile index 95d046fef..77695a569 100644 --- a/demos/ARM7-AT91SAM7X-UIP-GCC/Makefile +++ b/demos/ARM7-AT91SAM7X-UIP-GCC/Makefile @@ -143,10 +143,10 @@ AOPT = TOPT = -mthumb -DTHUMB
# Define C warning options here
-CWARN = -Wall -Wstrict-prototypes
+CWARN = -Wall -Wextra -Wstrict-prototypes
# Define C++ warning options here
-CPPWARN = -Wall
+CPPWARN = -Wall -Wextra
#
# Compiler settings
diff --git a/demos/ARM7-AT91SAM7X-UIP-GCC/main.c b/demos/ARM7-AT91SAM7X-UIP-GCC/main.c index 0474ce008..5b366b0b0 100644 --- a/demos/ARM7-AT91SAM7X-UIP-GCC/main.c +++ b/demos/ARM7-AT91SAM7X-UIP-GCC/main.c @@ -31,6 +31,7 @@ static WORKING_AREA(waThread1, 128); static msg_t Thread1(void *arg) {
+ (void)arg;
while (TRUE) {
palSetPad(IOPORT2, PIOB_LCD_BL);
chThdSleepMilliseconds(100);
@@ -46,6 +47,9 @@ static msg_t Thread1(void *arg) { */
int main(int argc, char **argv) {
+ (void)argc;
+ (void)argv;
+
/*
* Activates the serial driver 2 using the driver default configuration.
*/
diff --git a/demos/ARM7-AT91SAM7X-UIP-GCC/web/webthread.c b/demos/ARM7-AT91SAM7X-UIP-GCC/web/webthread.c index 12c3b8405..1be4df645 100644 --- a/demos/ARM7-AT91SAM7X-UIP-GCC/web/webthread.c +++ b/demos/ARM7-AT91SAM7X-UIP-GCC/web/webthread.c @@ -88,6 +88,7 @@ clock_time_t clock_time( void ) static void PeriodicTimerHandler(eventid_t id) {
int i;
+ (void)id;
for (i = 0; i < UIP_CONNS; i++) {
uip_periodic(i);
if (uip_len > 0) {
@@ -102,6 +103,7 @@ static void PeriodicTimerHandler(eventid_t id) { */
static void ARPTimerHandler(eventid_t id) {
+ (void)id;
(void)macPollLinkStatus(Ð1);
uip_arp_timer();
}
@@ -111,6 +113,7 @@ static void ARPTimerHandler(eventid_t id) { */
static void FrameReceivedHandler(eventid_t id) {
+ (void)id;
while ((uip_len = network_device_read()) > 0) {
if (BUF->type == HTONS(UIP_ETHTYPE_IP)) {
uip_arp_ipin();
@@ -143,6 +146,8 @@ msg_t WebThread(void *p) { EventListener el0, el1, el2;
uip_ipaddr_t ipaddr;
+ (void)p;
+
/*
* Event sources setup.
*/
|