diff options
Diffstat (limited to 'demos/ARMCM3-STM32F103')
-rw-r--r-- | demos/ARMCM3-STM32F103/Makefile | 11 | ||||
-rw-r--r-- | demos/ARMCM3-STM32F103/chconf.h | 12 | ||||
-rw-r--r-- | demos/ARMCM3-STM32F103/halconf.h | 34 | ||||
-rw-r--r-- | demos/ARMCM3-STM32F103/iar/ch.ewp | 249 | ||||
-rw-r--r-- | demos/ARMCM3-STM32F103/keil/ch.uvproj | 116 | ||||
-rw-r--r-- | demos/ARMCM3-STM32F103/mcuconf.h | 27 |
6 files changed, 297 insertions, 152 deletions
diff --git a/demos/ARMCM3-STM32F103/Makefile b/demos/ARMCM3-STM32F103/Makefile index 4d4ba0246..f9c6ec62a 100644 --- a/demos/ARMCM3-STM32F103/Makefile +++ b/demos/ARMCM3-STM32F103/Makefile @@ -8,6 +8,11 @@ ifeq ($(USE_OPT),) USE_OPT = -O2 -ggdb -fomit-frame-pointer -falign-functions=16
endif
+# C specific options here (added to USE_OPT).
+ifeq ($(USE_COPT),)
+ USE_COPT =
+endif
+
# C++ specific options here (added to USE_OPT).
ifeq ($(USE_CPPOPT),)
USE_CPPOPT = -fno-rtti
@@ -23,9 +28,9 @@ ifeq ($(USE_THUMB),) USE_THUMB = yes
endif
-# Enable register caching optimization (read documentation).
-ifeq ($(USE_CURRP_CACHING),)
- USE_CURRP_CACHING = no
+# Enable this if you want to see the full log while compiling.
+ifeq ($(USE_VERBOSE_COMPILE),)
+ USE_VERBOSE_COMPILE = no
endif
#
diff --git a/demos/ARMCM3-STM32F103/chconf.h b/demos/ARMCM3-STM32F103/chconf.h index a5d129956..9dd831c96 100644 --- a/demos/ARMCM3-STM32F103/chconf.h +++ b/demos/ARMCM3-STM32F103/chconf.h @@ -361,7 +361,7 @@ * @note The default is @p FALSE.
*/
#if !defined(CH_DBG_SYSTEM_STATE_CHECK) || defined(__DOXYGEN__)
-#define CH_DBG_SYSTEM_STATE_CHECK TRUE
+#define CH_DBG_SYSTEM_STATE_CHECK FALSE
#endif
/**
@@ -372,7 +372,7 @@ * @note The default is @p FALSE.
*/
#if !defined(CH_DBG_ENABLE_CHECKS) || defined(__DOXYGEN__)
-#define CH_DBG_ENABLE_CHECKS TRUE
+#define CH_DBG_ENABLE_CHECKS FALSE
#endif
/**
@@ -384,7 +384,7 @@ * @note The default is @p FALSE.
*/
#if !defined(CH_DBG_ENABLE_ASSERTS) || defined(__DOXYGEN__)
-#define CH_DBG_ENABLE_ASSERTS TRUE
+#define CH_DBG_ENABLE_ASSERTS FALSE
#endif
/**
@@ -395,7 +395,7 @@ * @note The default is @p FALSE.
*/
#if !defined(CH_DBG_ENABLE_TRACE) || defined(__DOXYGEN__)
-#define CH_DBG_ENABLE_TRACE TRUE
+#define CH_DBG_ENABLE_TRACE FALSE
#endif
/**
@@ -409,7 +409,7 @@ * @p panic_msg variable set to @p NULL.
*/
#if !defined(CH_DBG_ENABLE_STACK_CHECK) || defined(__DOXYGEN__)
-#define CH_DBG_ENABLE_STACK_CHECK TRUE
+#define CH_DBG_ENABLE_STACK_CHECK FALSE
#endif
/**
@@ -421,7 +421,7 @@ * @note The default is @p FALSE.
*/
#if !defined(CH_DBG_FILL_THREADS) || defined(__DOXYGEN__)
-#define CH_DBG_FILL_THREADS TRUE
+#define CH_DBG_FILL_THREADS FALSE
#endif
/**
diff --git a/demos/ARMCM3-STM32F103/halconf.h b/demos/ARMCM3-STM32F103/halconf.h index d36e56ec7..b4fb49092 100644 --- a/demos/ARMCM3-STM32F103/halconf.h +++ b/demos/ARMCM3-STM32F103/halconf.h @@ -56,6 +56,13 @@ #endif
/**
+ * @brief Enables the EXT subsystem.
+ */
+#if !defined(HAL_USE_EXT) || defined(__DOXYGEN__)
+#define HAL_USE_EXT FALSE
+#endif
+
+/**
* @brief Enables the GPT subsystem.
*/
#if !defined(HAL_USE_GPT) || defined(__DOXYGEN__)
@@ -98,6 +105,13 @@ #endif
/**
+ * @brief Enables the RTC subsystem.
+ */
+#if !defined(HAL_USE_RTC) || defined(__DOXYGEN__)
+#define HAL_USE_RTC FALSE
+#endif
+
+/**
* @brief Enables the SDC subsystem.
*/
#if !defined(HAL_USE_SDC) || defined(__DOXYGEN__)
@@ -185,6 +199,13 @@ /* MAC driver related settings. */
/*===========================================================================*/
+/**
+ * @brief Enables an event sources for incoming packets.
+ */
+#if !defined(MAC_USE_EVENTS) || defined(__DOXYGEN__)
+#define MAC_USE_EVENTS TRUE
+#endif
+
/*===========================================================================*/
/* MMC_SPI driver related settings. */
/*===========================================================================*/
@@ -235,16 +256,9 @@ #endif
/*===========================================================================*/
-/* PAL driver related settings. */
-/*===========================================================================*/
-
-/*===========================================================================*/
-/* PWM driver related settings. */
-/*===========================================================================*/
-
-/*===========================================================================*/
/* SDC driver related settings. */
/*===========================================================================*/
+
/**
* @brief Number of initialization attempts before rejecting the card.
* @note Attempts are performed at 10mS intevals.
@@ -316,10 +330,6 @@ #define SPI_USE_MUTUAL_EXCLUSION TRUE
#endif
-/*===========================================================================*/
-/* UART driver related settings. */
-/*===========================================================================*/
-
#endif /* _HALCONF_H_ */
/** @} */
diff --git a/demos/ARMCM3-STM32F103/iar/ch.ewp b/demos/ARMCM3-STM32F103/iar/ch.ewp index 085175d5f..e71bb10e3 100644 --- a/demos/ARMCM3-STM32F103/iar/ch.ewp +++ b/demos/ARMCM3-STM32F103/iar/ch.ewp @@ -12,7 +12,7 @@ <name>General</name>
<archiveVersion>3</archiveVersion>
<data>
- <version>18</version>
+ <version>21</version>
<wantNonLocal>1</wantNonLocal>
<debug>1</debug>
<option>
@@ -29,7 +29,7 @@ </option>
<option>
<name>Variant</name>
- <version>17</version>
+ <version>19</version>
<state>37</state>
</option>
<option>
@@ -38,8 +38,8 @@ </option>
<option>
<name>Input variant</name>
- <version>1</version>
- <state>3</state>
+ <version>3</version>
+ <state>6</state>
</option>
<option>
<name>Input description</name>
@@ -47,8 +47,8 @@ </option>
<option>
<name>Output variant</name>
- <version>0</version>
- <state>3</state>
+ <version>2</version>
+ <state>7</state>
</option>
<option>
<name>Output description</name>
@@ -60,7 +60,7 @@ </option>
<option>
<name>FPU</name>
- <version>1</version>
+ <version>2</version>
<state>0</state>
</option>
<option>
@@ -87,7 +87,7 @@ </option>
<option>
<name>OGLastSavedByProductVersion</name>
- <state>6.10.1.52170</state>
+ <state>6.20.2.52635</state>
</option>
<option>
<name>GeneralEnableMisra</name>
@@ -135,13 +135,31 @@ <name>RTConfigPath2</name>
<state>$TOOLKIT_DIR$\INC\c\DLib_Config_Normal.h</state>
</option>
+ <option>
+ <name>GFPUCoreSlave</name>
+ <version>19</version>
+ <state>37</state>
+ </option>
+ <option>
+ <name>GBECoreSlave</name>
+ <version>19</version>
+ <state>37</state>
+ </option>
+ <option>
+ <name>OGUseCmsis</name>
+ <state>0</state>
+ </option>
+ <option>
+ <name>OGUseCmsisDspLib</name>
+ <state>0</state>
+ </option>
</data>
</settings>
<settings>
<name>ICCARM</name>
<archiveVersion>2</archiveVersion>
<data>
- <version>26</version>
+ <version>28</version>
<wantNonLocal>1</wantNonLocal>
<debug>1</debug>
<option>
@@ -277,10 +295,15 @@ <name>CCIncludePath2</name>
<state>$PROJ_DIR$\..\</state>
<state>$PROJ_DIR$\..\..\..\os\kernel\include</state>
+ <state>$PROJ_DIR$\..\..\..\os\ports\common\ARMCMx\CMSIS\include</state>
<state>$PROJ_DIR$\..\..\..\os\ports\IAR\ARMCMx</state>
- <state>$PROJ_DIR$\..\..\..\os\ports\IAR\ARMCMx\STM32</state>
+ <state>$PROJ_DIR$\..\..\..\os\ports\IAR\ARMCMx\STM32F1xx</state>
<state>$PROJ_DIR$\..\..\..\os\hal\include</state>
<state>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32</state>
+ <state>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\DMAv1</state>
+ <state>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\GPIOv1</state>
+ <state>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\USBv1</state>
+ <state>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32F1xx</state>
<state>$PROJ_DIR$\..\..\..\boards\OLIMEX_STM32_P103</state>
<state>$PROJ_DIR$\..\..\..\test</state>
</option>
@@ -364,11 +387,15 @@ <state>1</state>
</option>
<option>
- <name>IccRelaxedFpPrecision</name>
+ <name>IccCppInlineSemantics</name>
<state>0</state>
</option>
<option>
- <name>IccCppInlineSemantics</name>
+ <name>IccCmsis</name>
+ <state>1</state>
+ </option>
+ <option>
+ <name>IccFloatSemantics</name>
<state>0</state>
</option>
</data>
@@ -523,8 +550,8 @@ </option>
<option>
<name>AUserIncludes</name>
- <state>$PROJ_DIR$\..\</state>
- <state>$PROJ_DIR$\..\..\..\os\ports\IAR\ARMCMx\STM32</state>
+ <state>$PROJ_DIR$\..</state>
+ <state>$PROJ_DIR$\..\..\..\os\ports\IAR\ARMCMx\STM32F1xx</state>
<state>$PROJ_DIR$\..\..\..\boards\OLIMEX_STM32_P103</state>
</option>
<option>
@@ -592,7 +619,7 @@ <name>ILINK</name>
<archiveVersion>0</archiveVersion>
<data>
- <version>11</version>
+ <version>13</version>
<wantNonLocal>1</wantNonLocal>
<debug>1</debug>
<option>
@@ -838,6 +865,22 @@ <name>IlinkOptExceptionsForce</name>
<state>0</state>
</option>
+ <option>
+ <name>IlinkCmsis</name>
+ <state>1</state>
+ </option>
+ <option>
+ <name>IlinkOptMergeDuplSections</name>
+ <state>0</state>
+ </option>
+ <option>
+ <name>IlinkOptUseVfe</name>
+ <state>1</state>
+ </option>
+ <option>
+ <name>IlinkOptForceVfe</name>
+ <state>0</state>
+ </option>
</data>
</settings>
<settings>
@@ -877,7 +920,7 @@ <name>General</name>
<archiveVersion>3</archiveVersion>
<data>
- <version>18</version>
+ <version>21</version>
<wantNonLocal>1</wantNonLocal>
<debug>0</debug>
<option>
@@ -894,7 +937,7 @@ </option>
<option>
<name>Variant</name>
- <version>17</version>
+ <version>19</version>
<state>37</state>
</option>
<option>
@@ -903,8 +946,8 @@ </option>
<option>
<name>Input variant</name>
- <version>1</version>
- <state>3</state>
+ <version>3</version>
+ <state>6</state>
</option>
<option>
<name>Input description</name>
@@ -912,8 +955,8 @@ </option>
<option>
<name>Output variant</name>
- <version>0</version>
- <state>3</state>
+ <version>2</version>
+ <state>7</state>
</option>
<option>
<name>Output description</name>
@@ -925,7 +968,7 @@ </option>
<option>
<name>FPU</name>
- <version>1</version>
+ <version>2</version>
<state>0</state>
</option>
<option>
@@ -952,7 +995,7 @@ </option>
<option>
<name>OGLastSavedByProductVersion</name>
- <state>6.10.1.52170</state>
+ <state>6.21.4.52945</state>
</option>
<option>
<name>GeneralEnableMisra</name>
@@ -1000,13 +1043,31 @@ <name>RTConfigPath2</name>
<state>$TOOLKIT_DIR$\INC\c\DLib_Config_Normal.h</state>
</option>
+ <option>
+ <name>GFPUCoreSlave</name>
+ <version>19</version>
+ <state>37</state>
+ </option>
+ <option>
+ <name>GBECoreSlave</name>
+ <version>19</version>
+ <state>37</state>
+ </option>
+ <option>
+ <name>OGUseCmsis</name>
+ <state>0</state>
+ </option>
+ <option>
+ <name>OGUseCmsisDspLib</name>
+ <state>0</state>
+ </option>
</data>
</settings>
<settings>
<name>ICCARM</name>
<archiveVersion>2</archiveVersion>
<data>
- <version>26</version>
+ <version>28</version>
<wantNonLocal>1</wantNonLocal>
<debug>0</debug>
<option>
@@ -1142,10 +1203,15 @@ <name>CCIncludePath2</name>
<state>$PROJ_DIR$\..\</state>
<state>$PROJ_DIR$\..\..\..\os\kernel\include</state>
+ <state>$PROJ_DIR$\..\..\..\os\ports\common\ARMCMx\CMSIS\include</state>
<state>$PROJ_DIR$\..\..\..\os\ports\IAR\ARMCMx</state>
- <state>$PROJ_DIR$\..\..\..\os\ports\IAR\ARMCMx\STM32</state>
+ <state>$PROJ_DIR$\..\..\..\os\ports\IAR\ARMCMx\STM32F1xx</state>
<state>$PROJ_DIR$\..\..\..\os\hal\include</state>
<state>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32</state>
+ <state>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\DMAv1</state>
+ <state>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\GPIOv1</state>
+ <state>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\USBv1</state>
+ <state>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32F1xx</state>
<state>$PROJ_DIR$\..\..\..\boards\OLIMEX_STM32_P103</state>
<state>$PROJ_DIR$\..\..\..\test</state>
</option>
@@ -1229,11 +1295,15 @@ <state>1</state>
</option>
<option>
- <name>IccRelaxedFpPrecision</name>
+ <name>IccCppInlineSemantics</name>
<state>0</state>
</option>
<option>
- <name>IccCppInlineSemantics</name>
+ <name>IccCmsis</name>
+ <state>1</state>
+ </option>
+ <option>
+ <name>IccFloatSemantics</name>
<state>0</state>
</option>
</data>
@@ -1388,8 +1458,8 @@ </option>
<option>
<name>AUserIncludes</name>
- <state>$PROJ_DIR$\..\</state>
- <state>$PROJ_DIR$\..\..\..\os\ports\IAR\ARMCMx\STM32</state>
+ <state>$PROJ_DIR$\..</state>
+ <state>$PROJ_DIR$\..\..\..\os\ports\IAR\ARMCMx\STM32F1xx</state>
<state>$PROJ_DIR$\..\..\..\boards\OLIMEX_STM32_P103</state>
</option>
<option>
@@ -1457,7 +1527,7 @@ <name>ILINK</name>
<archiveVersion>0</archiveVersion>
<data>
- <version>11</version>
+ <version>13</version>
<wantNonLocal>1</wantNonLocal>
<debug>0</debug>
<option>
@@ -1703,6 +1773,22 @@ <name>IlinkOptExceptionsForce</name>
<state>0</state>
</option>
+ <option>
+ <name>IlinkCmsis</name>
+ <state>1</state>
+ </option>
+ <option>
+ <name>IlinkOptMergeDuplSections</name>
+ <state>0</state>
+ </option>
+ <option>
+ <name>IlinkOptUseVfe</name>
+ <state>1</state>
+ </option>
+ <option>
+ <name>IlinkOptForceVfe</name>
+ <state>0</state>
+ </option>
</data>
</settings>
<settings>
@@ -1754,12 +1840,21 @@ <name>$PROJ_DIR$\..\..\..\os\hal\include\can.h</name>
</file>
<file>
+ <name>$PROJ_DIR$\..\..\..\os\hal\include\ext.h</name>
+ </file>
+ <file>
+ <name>$PROJ_DIR$\..\..\..\os\hal\include\gpt.h</name>
+ </file>
+ <file>
<name>$PROJ_DIR$\..\..\..\os\hal\include\hal.h</name>
</file>
<file>
<name>$PROJ_DIR$\..\..\..\os\hal\include\i2c.h</name>
</file>
<file>
+ <name>$PROJ_DIR$\..\..\..\os\hal\include\icu.h</name>
+ </file>
+ <file>
<name>$PROJ_DIR$\..\..\..\os\hal\include\mac.h</name>
</file>
<file>
@@ -1775,14 +1870,29 @@ <name>$PROJ_DIR$\..\..\..\os\hal\include\pwm.h</name>
</file>
<file>
+ <name>$PROJ_DIR$\..\..\..\os\hal\include\rtc.h</name>
+ </file>
+ <file>
+ <name>$PROJ_DIR$\..\..\..\os\hal\include\sdc.h</name>
+ </file>
+ <file>
<name>$PROJ_DIR$\..\..\..\os\hal\include\serial.h</name>
</file>
<file>
+ <name>$PROJ_DIR$\..\..\..\os\hal\include\serial_usb.h</name>
+ </file>
+ <file>
<name>$PROJ_DIR$\..\..\..\os\hal\include\spi.h</name>
</file>
<file>
<name>$PROJ_DIR$\..\..\..\os\hal\include\uart.h</name>
</file>
+ <file>
+ <name>$PROJ_DIR$\..\..\..\os\hal\include\usb.h</name>
+ </file>
+ <file>
+ <name>$PROJ_DIR$\..\..\..\os\hal\include\usb_cdc.h</name>
+ </file>
</group>
<group>
<name>src</name>
@@ -1793,12 +1903,21 @@ <name>$PROJ_DIR$\..\..\..\os\hal\src\can.c</name>
</file>
<file>
+ <name>$PROJ_DIR$\..\..\..\os\hal\src\ext.c</name>
+ </file>
+ <file>
+ <name>$PROJ_DIR$\..\..\..\os\hal\src\gpt.c</name>
+ </file>
+ <file>
<name>$PROJ_DIR$\..\..\..\os\hal\src\hal.c</name>
</file>
<file>
<name>$PROJ_DIR$\..\..\..\os\hal\src\i2c.c</name>
</file>
<file>
+ <name>$PROJ_DIR$\..\..\..\os\hal\src\icu.c</name>
+ </file>
+ <file>
<name>$PROJ_DIR$\..\..\..\os\hal\src\mac.c</name>
</file>
<file>
@@ -1811,14 +1930,26 @@ <name>$PROJ_DIR$\..\..\..\os\hal\src\pwm.c</name>
</file>
<file>
+ <name>$PROJ_DIR$\..\..\..\os\hal\src\rtc.c</name>
+ </file>
+ <file>
+ <name>$PROJ_DIR$\..\..\..\os\hal\src\sdc.c</name>
+ </file>
+ <file>
<name>$PROJ_DIR$\..\..\..\os\hal\src\serial.c</name>
</file>
<file>
+ <name>$PROJ_DIR$\..\..\..\os\hal\src\serial_usb.c</name>
+ </file>
+ <file>
<name>$PROJ_DIR$\..\..\..\os\hal\src\spi.c</name>
</file>
<file>
<name>$PROJ_DIR$\..\..\..\os\hal\src\uart.c</name>
</file>
+ <file>
+ <name>$PROJ_DIR$\..\..\..\os\hal\src\usb.c</name>
+ </file>
</group>
</group>
<group>
@@ -1953,46 +2084,25 @@ <group>
<name>platform</name>
<file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\adc_lld.c</name>
- </file>
- <file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\adc_lld.h</name>
- </file>
- <file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\can_lld.c</name>
+ <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32F1xx\hal_lld.c</name>
</file>
<file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\can_lld.h</name>
+ <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32F1xx\hal_lld.h</name>
</file>
<file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\core_cm3.h</name>
+ <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32F1xx\hal_lld_f100.h</name>
</file>
<file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\hal_lld.c</name>
+ <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32F1xx\hal_lld_f103.h</name>
</file>
<file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\hal_lld.h</name>
+ <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32F1xx\hal_lld_f105_f107.h</name>
</file>
<file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\hal_lld_f100.h</name>
+ <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\GPIOv1\pal_lld.c</name>
</file>
<file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\hal_lld_f103.h</name>
- </file>
- <file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\hal_lld_f105_f107.h</name>
- </file>
- <file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\pal_lld.c</name>
- </file>
- <file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\pal_lld.h</name>
- </file>
- <file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\pwm_lld.c</name>
- </file>
- <file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\pwm_lld.h</name>
+ <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\GPIOv1\pal_lld.h</name>
</file>
<file>
<name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\serial_lld.c</name>
@@ -2001,36 +2111,27 @@ <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\serial_lld.h</name>
</file>
<file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\spi_lld.c</name>
- </file>
- <file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\spi_lld.h</name>
- </file>
- <file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\stm32_dma.c</name>
- </file>
- <file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\stm32_dma.h</name>
+ <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32F1xx\stm32_dma.c</name>
</file>
<file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\stm32f10x.h</name>
+ <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32F1xx\stm32_dma.h</name>
</file>
<file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\uart_lld.c</name>
+ <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32F1xx\stm32_rcc.h</name>
</file>
<file>
- <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32\uart_lld.h</name>
+ <name>$PROJ_DIR$\..\..\..\os\hal\platforms\STM32F1xx\stm32f10x.h</name>
</file>
</group>
<group>
<name>port</name>
<group>
- <name>STM32</name>
+ <name>STM32F1xx</name>
<file>
- <name>$PROJ_DIR$\..\..\..\os\ports\IAR\ARMCMx\STM32\cmparams.h</name>
+ <name>$PROJ_DIR$\..\..\..\os\ports\IAR\ARMCMx\STM32F1xx\cmparams.h</name>
</file>
<file>
- <name>$PROJ_DIR$\..\..\..\os\ports\IAR\ARMCMx\STM32\vectors.s</name>
+ <name>$PROJ_DIR$\..\..\..\os\ports\IAR\ARMCMx\STM32F1xx\vectors.s</name>
</file>
</group>
<file>
diff --git a/demos/ARMCM3-STM32F103/keil/ch.uvproj b/demos/ARMCM3-STM32F103/keil/ch.uvproj index 3f8ff22bd..80066e03a 100644 --- a/demos/ARMCM3-STM32F103/keil/ch.uvproj +++ b/demos/ARMCM3-STM32F103/keil/ch.uvproj @@ -346,7 +346,7 @@ <MiscControls></MiscControls> <Define>__heap_base__=Image$$RW_IRAM1$$ZI$$Limit __heap_end__=Image$$RW_IRAM2$$Base</Define> <Undefine></Undefine> - <IncludePath>..\;..\..\..\os\kernel\include;..\..\..\os\ports\RVCT\ARMCMx;..\..\..\os\ports\RVCT\ARMCMx\STM32;..\..\..\os\hal\include;..\..\..\os\hal\platforms\STM32;..\..\..\boards\OLIMEX_STM32_P103;..\..\..\test</IncludePath> + <IncludePath>..\;..\..\..\os\kernel\include;..\..\..\os\ports\common\ARMCMx\CMSIS\include;..\..\..\os\ports\RVCT\ARMCMx;..\..\..\os\ports\RVCT\ARMCMx\STM32F1xx;..\..\..\os\hal\include;..\..\..\os\hal\platforms\STM32;..\..\..\os\hal\platforms\STM32\GPIOv1;..\..\..\os\hal\platforms\STM32\DMAv1;..\..\..\os\hal\platforms\STM32\USBv1;..\..\..\os\hal\platforms\STM32F1xx;..\..\..\boards\OLIMEX_STM32_P103;..\..\..\test</IncludePath> </VariousControls> </Cads> <Aads> @@ -361,7 +361,7 @@ <MiscControls>--cpreproc</MiscControls> <Define></Define> <Undefine></Undefine> - <IncludePath>..\;..\..\..\boards\OLIMEX_STM32_P103;..\..\..\os\ports\RVCT\ARMCMx\STM32</IncludePath> + <IncludePath>..\;..\..\..\boards\OLIMEX_STM32_P103;..\..\..\os\ports\RVCT\ARMCMx\STM32F1xx</IncludePath> </VariousControls> </Aads> <LDads> @@ -409,7 +409,7 @@ <File> <FileName>vectors.s</FileName> <FileType>2</FileType> - <FilePath>..\..\..\os\ports\RVCT\ARMCMx\STM32\vectors.s</FilePath> + <FilePath>D:\Progetti\ChibiOS-RT\os\ports\RVCT\ARMCMx\STM32F1xx\vectors.s</FilePath> </File> <File> <FileName>chcoreasm_v7m.s</FileName> @@ -786,115 +786,125 @@ <FileType>5</FileType> <FilePath>..\..\..\os\hal\include\uart.h</FilePath> </File> - </Files> - </Group> - <Group> - <GroupName>platform</GroupName> - <Files> <File> - <FileName>adc_lld.c</FileName> + <FileName>ext.c</FileName> <FileType>1</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\adc_lld.c</FilePath> + <FilePath>..\..\..\os\hal\src\ext.c</FilePath> </File> <File> - <FileName>can_lld.c</FileName> + <FileName>gpt.c</FileName> <FileType>1</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\can_lld.c</FilePath> + <FilePath>..\..\..\os\hal\src\gpt.c</FilePath> </File> <File> - <FileName>hal_lld.c</FileName> + <FileName>icu.c</FileName> <FileType>1</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\hal_lld.c</FilePath> + <FilePath>..\..\..\os\hal\src\icu.c</FilePath> </File> <File> - <FileName>pal_lld.c</FileName> + <FileName>rtc.c</FileName> <FileType>1</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\pal_lld.c</FilePath> + <FilePath>..\..\..\os\hal\src\rtc.c</FilePath> </File> <File> - <FileName>pwm_lld.c</FileName> + <FileName>sdc.c</FileName> <FileType>1</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\pwm_lld.c</FilePath> + <FilePath>..\..\..\os\hal\src\sdc.c</FilePath> </File> <File> - <FileName>serial_lld.c</FileName> + <FileName>serial_usb.c</FileName> <FileType>1</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\serial_lld.c</FilePath> + <FilePath>..\..\..\os\hal\src\serial_usb.c</FilePath> </File> <File> - <FileName>spi_lld.c</FileName> + <FileName>usb.c</FileName> <FileType>1</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\spi_lld.c</FilePath> + <FilePath>..\..\..\os\hal\src\usb.c</FilePath> </File> <File> - <FileName>stm32_dma.c</FileName> - <FileType>1</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\stm32_dma.c</FilePath> + <FileName>ext.h</FileName> + <FileType>5</FileType> + <FilePath>..\..\..\os\hal\include\ext.h</FilePath> </File> <File> - <FileName>uart_lld.c</FileName> - <FileType>1</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\uart_lld.c</FilePath> + <FileName>gpt.h</FileName> + <FileType>5</FileType> + <FilePath>..\..\..\os\hal\include\gpt.h</FilePath> </File> <File> - <FileName>adc_lld.h</FileName> + <FileName>icu.h</FileName> <FileType>5</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\adc_lld.h</FilePath> + <FilePath>..\..\..\os\hal\include\icu.h</FilePath> </File> <File> - <FileName>can_lld.h</FileName> + <FileName>rtc.h</FileName> <FileType>5</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\can_lld.h</FilePath> + <FilePath>..\..\..\os\hal\include\rtc.h</FilePath> </File> <File> - <FileName>core_cm3.h</FileName> + <FileName>sdc.h</FileName> <FileType>5</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\core_cm3.h</FilePath> + <FilePath>..\..\..\os\hal\include\sdc.h</FilePath> </File> <File> - <FileName>hal_lld.h</FileName> + <FileName>serial_usb.h</FileName> <FileType>5</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\hal_lld.h</FilePath> + <FilePath>..\..\..\os\hal\include\serial_usb.h</FilePath> </File> <File> - <FileName>hal_lld_f103.h</FileName> + <FileName>usb.h</FileName> <FileType>5</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\hal_lld_f103.h</FilePath> + <FilePath>..\..\..\os\hal\include\usb.h</FilePath> </File> <File> - <FileName>pal_lld.h</FileName> + <FileName>usb_cdc.h</FileName> <FileType>5</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\pal_lld.h</FilePath> + <FilePath>..\..\..\os\hal\include\usb_cdc.h</FilePath> + </File> + </Files> + </Group> + <Group> + <GroupName>platform</GroupName> + <Files> + <File> + <FileName>hal_lld.c</FileName> + <FileType>1</FileType> + <FilePath>D:\Progetti\ChibiOS-RT\os\hal\platforms\STM32F1xx\hal_lld.c</FilePath> </File> <File> - <FileName>pwm_lld.h</FileName> - <FileType>5</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\pwm_lld.h</FilePath> + <FileName>pal_lld.c</FileName> + <FileType>1</FileType> + <FilePath>D:\Progetti\ChibiOS-RT\os\hal\platforms\STM32\GPIOv1\pal_lld.c</FilePath> </File> <File> - <FileName>serial_lld.h</FileName> + <FileName>serial_lld.c</FileName> + <FileType>1</FileType> + <FilePath>..\..\..\os\hal\platforms\STM32\serial_lld.c</FilePath> + </File> + <File> + <FileName>hal_lld.h</FileName> <FileType>5</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\serial_lld.h</FilePath> + <FilePath>D:\Progetti\ChibiOS-RT\os\hal\platforms\STM32F1xx\hal_lld.h</FilePath> </File> <File> - <FileName>spi_lld.h</FileName> + <FileName>hal_lld_f103.h</FileName> <FileType>5</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\spi_lld.h</FilePath> + <FilePath>D:\Progetti\ChibiOS-RT\os\hal\platforms\STM32F1xx\hal_lld_f103.h</FilePath> </File> <File> - <FileName>stm32_dma.h</FileName> + <FileName>pal_lld.h</FileName> <FileType>5</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\stm32_dma.h</FilePath> + <FilePath>D:\Progetti\ChibiOS-RT\os\hal\platforms\STM32\GPIOv1\pal_lld.h</FilePath> </File> <File> - <FileName>stm32f10x.h</FileName> + <FileName>serial_lld.h</FileName> <FileType>5</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\stm32f10x.h</FilePath> + <FilePath>..\..\..\os\hal\platforms\STM32\serial_lld.h</FilePath> </File> <File> - <FileName>uart_lld.h</FileName> + <FileName>stm32f10x.h</FileName> <FileType>5</FileType> - <FilePath>..\..\..\os\hal\platforms\STM32\uart_lld.h</FilePath> + <FilePath>D:\Progetti\ChibiOS-RT\os\hal\platforms\STM32F1xx\stm32f10x.h</FilePath> </File> </Files> </Group> diff --git a/demos/ARMCM3-STM32F103/mcuconf.h b/demos/ARMCM3-STM32F103/mcuconf.h index 88a5aa33b..c6dc0ce8a 100644 --- a/demos/ARMCM3-STM32F103/mcuconf.h +++ b/demos/ARMCM3-STM32F103/mcuconf.h @@ -52,7 +52,6 @@ #define STM32_ADC_USE_ADC1 TRUE
#define STM32_ADC_ADC1_DMA_PRIORITY 2
#define STM32_ADC_ADC1_IRQ_PRIORITY 5
-#define STM32_ADC_DMA_ERROR_HOOK(adcp) chSysHalt()
/*
* CAN driver system settings.
@@ -61,6 +60,21 @@ #define STM32_CAN_CAN1_IRQ_PRIORITY 11
/*
+ * EXT driver system settings.
+ */
+#define STM32_EXT_EXTI0_IRQ_PRIORITY 6
+#define STM32_EXT_EXTI1_IRQ_PRIORITY 6
+#define STM32_EXT_EXTI2_IRQ_PRIORITY 6
+#define STM32_EXT_EXTI3_IRQ_PRIORITY 6
+#define STM32_EXT_EXTI4_IRQ_PRIORITY 6
+#define STM32_EXT_EXTI5_9_IRQ_PRIORITY 6
+#define STM32_EXT_EXTI10_15_IRQ_PRIORITY 6
+#define STM32_EXT_EXTI16_IRQ_PRIORITY 6
+#define STM32_EXT_EXTI17_IRQ_PRIORITY 6
+#define STM32_EXT_EXTI18_IRQ_PRIORITY 6
+#define STM32_EXT_EXTI19_IRQ_PRIORITY 6
+
+/*
* GPT driver system settings.
*/
#define STM32_GPT_USE_TIM1 FALSE
@@ -68,7 +82,8 @@ #define STM32_GPT_USE_TIM3 FALSE
#define STM32_GPT_USE_TIM4 FALSE
#define STM32_GPT_USE_TIM5 FALSE
-#define STM32_GPT_USE_TIM8 FALSE#define STM32_GPT_TIM1_IRQ_PRIORITY 7
+#define STM32_GPT_USE_TIM8 FALSE
+#define STM32_GPT_TIM1_IRQ_PRIORITY 7
#define STM32_GPT_TIM2_IRQ_PRIORITY 7
#define STM32_GPT_TIM3_IRQ_PRIORITY 7
#define STM32_GPT_TIM4_IRQ_PRIORITY 7
@@ -82,7 +97,8 @@ #define STM32_ICU_USE_TIM3 FALSE
#define STM32_ICU_USE_TIM4 TRUE
#define STM32_ICU_USE_TIM5 FALSE
-#define STM32_ICU_USE_TIM8 FALSE#define STM32_ICU_TIM1_IRQ_PRIORITY 7
+#define STM32_ICU_USE_TIM8 FALSE
+#define STM32_ICU_TIM1_IRQ_PRIORITY 7
#define STM32_ICU_TIM2_IRQ_PRIORITY 7
#define STM32_ICU_TIM3_IRQ_PRIORITY 7
#define STM32_ICU_TIM4_IRQ_PRIORITY 7
@@ -97,7 +113,8 @@ #define STM32_PWM_USE_TIM3 FALSE
#define STM32_PWM_USE_TIM4 FALSE
#define STM32_PWM_USE_TIM5 FALSE
-#define STM32_PWM_USE_TIM8 FALSE#define STM32_PWM_TIM1_IRQ_PRIORITY 7
+#define STM32_PWM_USE_TIM8 FALSE
+#define STM32_PWM_TIM1_IRQ_PRIORITY 7
#define STM32_PWM_TIM2_IRQ_PRIORITY 7
#define STM32_PWM_TIM3_IRQ_PRIORITY 7
#define STM32_PWM_TIM4_IRQ_PRIORITY 7
@@ -111,11 +128,13 @@ #define STM32_SERIAL_USE_USART3 FALSE
#define STM32_SERIAL_USE_UART4 FALSE
#define STM32_SERIAL_USE_UART5 FALSE
+#define STM32_SERIAL_USE_USART6 FALSE
#define STM32_SERIAL_USART1_PRIORITY 12
#define STM32_SERIAL_USART2_PRIORITY 12
#define STM32_SERIAL_USART3_PRIORITY 12
#define STM32_SERIAL_UART4_PRIORITY 12
#define STM32_SERIAL_UART5_PRIORITY 12
+#define STM32_SERIAL_USART6_PRIORITY 12
/*
* SPI driver system settings.
|