diff options
Diffstat (limited to 'demos/AVR-ATmega128-GCC')
-rw-r--r-- | demos/AVR-ATmega128-GCC/Makefile | 2 | ||||
-rw-r--r-- | demos/AVR-ATmega128-GCC/board.c | 6 |
2 files changed, 7 insertions, 1 deletions
diff --git a/demos/AVR-ATmega128-GCC/Makefile b/demos/AVR-ATmega128-GCC/Makefile index dea57ee61..66cc846c7 100644 --- a/demos/AVR-ATmega128-GCC/Makefile +++ b/demos/AVR-ATmega128-GCC/Makefile @@ -80,7 +80,7 @@ OBJDIR = . # List C source files here. (C dependencies are automatically generated.)
-SRC = ../../ports/AVR/chcore.c \
+SRC = ../../ports/AVR/chcore.c ../../ports/AVR/avr_serial.c \
../../src/chinit.c ../../src/chdebug.c ../../src/chlists.c ../../src/chdelta.c \
../../src/chschd.c ../../src/chthreads.c ../../src/chsem.c ../../src/chmtx.c \
../../src/chevents.c ../../src/chmsg.c ../../src/chsleep.c ../../src/chqueues.c \
diff --git a/demos/AVR-ATmega128-GCC/board.c b/demos/AVR-ATmega128-GCC/board.c index 6ac43a218..03907d391 100644 --- a/demos/AVR-ATmega128-GCC/board.c +++ b/demos/AVR-ATmega128-GCC/board.c @@ -23,6 +23,7 @@ #include <avr/interrupt.h>
#include "board.h"
+#include "avr_serial.h"
ISR(TIMER0_COMP_vect) {
@@ -78,4 +79,9 @@ void hwinit(void) { TCNT0 = 0; // Reset counter.
TIFR = (1 << OCF0); // Reset pending (if any).
TIMSK = (1 << OCIE0); // Interrupt on compare.
+
+ /*
+ * Other initializations.
+ */
+ InitSerial();
}
|