diff options
Diffstat (limited to 'demos/STM32/NIL-STM32F051-DISCOVERY')
-rw-r--r-- | demos/STM32/NIL-STM32F051-DISCOVERY/Makefile | 4 | ||||
-rw-r--r-- | demos/STM32/NIL-STM32F051-DISCOVERY/main.c | 7 |
2 files changed, 8 insertions, 3 deletions
diff --git a/demos/STM32/NIL-STM32F051-DISCOVERY/Makefile b/demos/STM32/NIL-STM32F051-DISCOVERY/Makefile index 223ff48e6..36e81274b 100644 --- a/demos/STM32/NIL-STM32F051-DISCOVERY/Makefile +++ b/demos/STM32/NIL-STM32F051-DISCOVERY/Makefile @@ -98,7 +98,9 @@ include $(CHIBIOS)/os/hal/osal/nil/osal.mk include $(CHIBIOS)/os/nil/nil.mk
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/port_v6m.mk
# Other files (optional).
-include $(CHIBIOS)/test/nil/test.mk
+include $(CHIBIOS)/test/lib/test.mk
+include $(CHIBIOS)/test/nil/nil_test.mk
+include $(CHIBIOS)/test/oslib/oslib_test.mk
# Define linker script file here
LDSCRIPT= $(STARTUPLD)/STM32F051x8.ld
diff --git a/demos/STM32/NIL-STM32F051-DISCOVERY/main.c b/demos/STM32/NIL-STM32F051-DISCOVERY/main.c index b6cb5b30d..7e4e13e80 100644 --- a/demos/STM32/NIL-STM32F051-DISCOVERY/main.c +++ b/demos/STM32/NIL-STM32F051-DISCOVERY/main.c @@ -17,6 +17,7 @@ #include "hal.h"
#include "ch.h"
#include "nil_test_root.h"
+#include "oslib_test_root.h"
/*
* Thread 1.
@@ -71,8 +72,10 @@ THD_FUNCTION(Thread3, arg) { /* Waiting for button push and activation of the test suite.*/
while (true) {
- if (palReadLine(LINE_BUTTON))
- test_execute((BaseSequentialStream *)&SD1, &rt_test_suite);
+ if (palReadLine(LINE_BUTTON)) {
+ test_execute((BaseSequentialStream *)&SD1, &nil_test_suite);
+ test_execute((BaseSequentialStream *)&SD1, &oslib_test_suite);
+ }
chThdSleepMilliseconds(500);
}
}
|