diff options
Diffstat (limited to 'demos/STM32/RT-STM32F051-DISCOVERY')
-rw-r--r-- | demos/STM32/RT-STM32F051-DISCOVERY/Makefile | 4 | ||||
-rw-r--r-- | demos/STM32/RT-STM32F051-DISCOVERY/main.c | 5 |
2 files changed, 7 insertions, 2 deletions
diff --git a/demos/STM32/RT-STM32F051-DISCOVERY/Makefile b/demos/STM32/RT-STM32F051-DISCOVERY/Makefile index 25d8f022e..ee65b9cb9 100644 --- a/demos/STM32/RT-STM32F051-DISCOVERY/Makefile +++ b/demos/STM32/RT-STM32F051-DISCOVERY/Makefile @@ -98,7 +98,9 @@ include $(CHIBIOS)/os/hal/osal/rt/osal.mk include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/port_v6m.mk
# Other files (optional).
-include $(CHIBIOS)/test/rt/test.mk
+include $(CHIBIOS)/test/lib/test.mk
+include $(CHIBIOS)/test/rt/rt_test.mk
+include $(CHIBIOS)/test/oslib/oslib_test.mk
# Define linker script file here
LDSCRIPT= $(STARTUPLD)/STM32F051x8.ld
diff --git a/demos/STM32/RT-STM32F051-DISCOVERY/main.c b/demos/STM32/RT-STM32F051-DISCOVERY/main.c index 33fb2be92..9e76b1e00 100644 --- a/demos/STM32/RT-STM32F051-DISCOVERY/main.c +++ b/demos/STM32/RT-STM32F051-DISCOVERY/main.c @@ -17,6 +17,7 @@ #include "ch.h"
#include "hal.h"
#include "rt_test_root.h"
+#include "oslib_test_root.h"
/*
* Blue LED blinker thread, times are in milliseconds.
@@ -86,8 +87,10 @@ int main(void) { * driver 1.
*/
while (true) {
- if (palReadPad(GPIOA, GPIOA_BUTTON))
+ if (palReadPad(GPIOA, GPIOA_BUTTON)) {
test_execute((BaseSequentialStream *)&SD1, &rt_test_suite);
+ test_execute((BaseSequentialStream *)&SD1, &oslib_test_suite);
+ }
chThdSleepMilliseconds(500);
}
}
|