aboutsummaryrefslogtreecommitdiffstats
path: root/demos/STM32/RT-STM32F103-MAPLEMINI
diff options
context:
space:
mode:
Diffstat (limited to 'demos/STM32/RT-STM32F103-MAPLEMINI')
-rw-r--r--demos/STM32/RT-STM32F103-MAPLEMINI/Makefile4
-rw-r--r--demos/STM32/RT-STM32F103-MAPLEMINI/main.c1
2 files changed, 3 insertions, 2 deletions
diff --git a/demos/STM32/RT-STM32F103-MAPLEMINI/Makefile b/demos/STM32/RT-STM32F103-MAPLEMINI/Makefile
index 5fc0bb1ee..a26f18744 100644
--- a/demos/STM32/RT-STM32F103-MAPLEMINI/Makefile
+++ b/demos/STM32/RT-STM32F103-MAPLEMINI/Makefile
@@ -101,7 +101,9 @@ include $(CHIBIOS)/os/hal/osal/rt/osal.mk
include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/port_v7m.mk
# Other files (optional).
-include $(CHIBIOS)/test/rt/test.mk
+include $(CHIBIOS)/test/lib/test.mk
+include $(CHIBIOS)/test/rt/rt_test.mk
+include $(CHIBIOS)/test/oslib/oslib_test.mk
include $(CHIBIOS)/os/hal/lib/streams/streams.mk
include $(CHIBIOS)/os/various/shell/shell.mk
diff --git a/demos/STM32/RT-STM32F103-MAPLEMINI/main.c b/demos/STM32/RT-STM32F103-MAPLEMINI/main.c
index ac267239a..4e1c7ac35 100644
--- a/demos/STM32/RT-STM32F103-MAPLEMINI/main.c
+++ b/demos/STM32/RT-STM32F103-MAPLEMINI/main.c
@@ -19,7 +19,6 @@
#include "ch.h"
#include "hal.h"
-#include "rt_test_root.h"
#include "shell.h"
#include "chprintf.h"