diff options
Diffstat (limited to 'demos/STM32/RT-STM32F107-OLIMEX_P107-LWIP')
-rw-r--r-- | demos/STM32/RT-STM32F107-OLIMEX_P107-LWIP/Makefile | 1 | ||||
-rw-r--r-- | demos/STM32/RT-STM32F107-OLIMEX_P107-LWIP/chconf.h | 4 | ||||
-rw-r--r-- | demos/STM32/RT-STM32F107-OLIMEX_P107-LWIP/main.c | 6 |
3 files changed, 6 insertions, 5 deletions
diff --git a/demos/STM32/RT-STM32F107-OLIMEX_P107-LWIP/Makefile b/demos/STM32/RT-STM32F107-OLIMEX_P107-LWIP/Makefile index bd6b03045..a70cbbe91 100644 --- a/demos/STM32/RT-STM32F107-OLIMEX_P107-LWIP/Makefile +++ b/demos/STM32/RT-STM32F107-OLIMEX_P107-LWIP/Makefile @@ -115,6 +115,7 @@ CSRC = $(STARTUPSRC) \ $(BOARDSRC) \
$(TESTSRC) \
$(LWSRC) \
+ $(CHIBIOS)/os/various/evtimer.c \
web/web.c main.c
# C++ sources that can be compiled in ARM or THUMB mode depending on the global
diff --git a/demos/STM32/RT-STM32F107-OLIMEX_P107-LWIP/chconf.h b/demos/STM32/RT-STM32F107-OLIMEX_P107-LWIP/chconf.h index ad6b53ade..0f3ef50d3 100644 --- a/demos/STM32/RT-STM32F107-OLIMEX_P107-LWIP/chconf.h +++ b/demos/STM32/RT-STM32F107-OLIMEX_P107-LWIP/chconf.h @@ -48,7 +48,7 @@ * @details Frequency of the system timer that drives the system ticks. This
* setting also defines the system tick time unit.
*/
-#define CH_CFG_ST_FREQUENCY 10000
+#define CH_CFG_ST_FREQUENCY 1000
/**
* @brief Time delta constant for the tick-less mode.
@@ -58,7 +58,7 @@ * The value one is not valid, timeouts are rounded up to
* this value.
*/
-#define CH_CFG_ST_TIMEDELTA 2
+#define CH_CFG_ST_TIMEDELTA 0
/** @} */
diff --git a/demos/STM32/RT-STM32F107-OLIMEX_P107-LWIP/main.c b/demos/STM32/RT-STM32F107-OLIMEX_P107-LWIP/main.c index f1896e953..e0524c8d9 100644 --- a/demos/STM32/RT-STM32F107-OLIMEX_P107-LWIP/main.c +++ b/demos/STM32/RT-STM32F107-OLIMEX_P107-LWIP/main.c @@ -25,8 +25,8 @@ /*
* Green LED blinker thread, times are in milliseconds.
*/
-static WORKING_AREA(waThread1, 128);
-static msg_t Thread1(void *arg) {
+static THD_WORKING_AREA(waThread1, 128);
+static THD_FUNCTION(Thread1, arg) {
(void)arg;
chRegSetThreadName("blinker");
@@ -76,7 +76,7 @@ int main(void) { */
while (true) {
if (palReadPad(GPIOC, GPIOC_SWITCH_TAMPER) == 0)
- TestThread(&SD3);
+ test_execute((BaseSequentialStream *)&SD3);
chThdSleepMilliseconds(500);
}
}
|