diff options
Diffstat (limited to 'demos/STM32/RT-STM32F746G-DISCOVERY')
-rw-r--r-- | demos/STM32/RT-STM32F746G-DISCOVERY/Makefile | 7 |
1 files changed, 6 insertions, 1 deletions
diff --git a/demos/STM32/RT-STM32F746G-DISCOVERY/Makefile b/demos/STM32/RT-STM32F746G-DISCOVERY/Makefile index 4a2ee7910..0273b285d 100644 --- a/demos/STM32/RT-STM32F746G-DISCOVERY/Makefile +++ b/demos/STM32/RT-STM32F746G-DISCOVERY/Makefile @@ -74,6 +74,11 @@ ifeq ($(USE_FPU),) USE_FPU = no
endif
+# FPU-related options.
+ifeq ($(USE_FPU_OPT),)
+ USE_FPU_OPT = -mfloat-abi=$(USE_FPU) -mfpu=fpv5-sp-d16 -fsingle-precision-constant
+endif
+
#
# Architecture or project specific options
##############################################################################
@@ -156,7 +161,7 @@ INCDIR = $(CHIBIOS)/os/license \ # Compiler settings
#
-MCU = cortex-m4
+MCU = cortex-m7
#TRGT = arm-elf-
TRGT = arm-none-eabi-
|