aboutsummaryrefslogtreecommitdiffstats
path: root/demos
diff options
context:
space:
mode:
Diffstat (limited to 'demos')
-rw-r--r--demos/ARMCM3-STM32F103ZG/Makefile1
-rw-r--r--demos/ARMCM3-STM32F103ZG/halconf.h2
2 files changed, 2 insertions, 1 deletions
diff --git a/demos/ARMCM3-STM32F103ZG/Makefile b/demos/ARMCM3-STM32F103ZG/Makefile
index 3c5bf32ec..d7a8b7490 100644
--- a/demos/ARMCM3-STM32F103ZG/Makefile
+++ b/demos/ARMCM3-STM32F103ZG/Makefile
@@ -63,6 +63,7 @@ include $(CHIBIOS)/os/hal/hal.mk
include $(CHIBIOS)/os/ports/GCC/ARMCMx/STM32/port.mk
include $(CHIBIOS)/os/kernel/kernel.mk
include $(CHIBIOS)/test/test.mk
+include $(CHIBIOS)/ext/fatfs/fatfs.mk
# C sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
diff --git a/demos/ARMCM3-STM32F103ZG/halconf.h b/demos/ARMCM3-STM32F103ZG/halconf.h
index d36e56ec7..682167d84 100644
--- a/demos/ARMCM3-STM32F103ZG/halconf.h
+++ b/demos/ARMCM3-STM32F103ZG/halconf.h
@@ -101,7 +101,7 @@
* @brief Enables the SDC subsystem.
*/
#if !defined(HAL_USE_SDC) || defined(__DOXYGEN__)
-#define HAL_USE_SDC FALSE
+#define HAL_USE_SDC TRUE
#endif
/**