aboutsummaryrefslogtreecommitdiffstats
path: root/demos
diff options
context:
space:
mode:
Diffstat (limited to 'demos')
-rw-r--r--demos/ARM7-AT91SAM7X-WEB-GCC/Makefile3
-rw-r--r--demos/ARM7-AT91SAM7X-WEB-GCC/Makefile.thumb3
-rw-r--r--demos/ARM7-AT91SAM7X-WEB-GCC/ch.ld2
3 files changed, 5 insertions, 3 deletions
diff --git a/demos/ARM7-AT91SAM7X-WEB-GCC/Makefile b/demos/ARM7-AT91SAM7X-WEB-GCC/Makefile
index 243d525f8..b7b859220 100644
--- a/demos/ARM7-AT91SAM7X-WEB-GCC/Makefile
+++ b/demos/ARM7-AT91SAM7X-WEB-GCC/Makefile
@@ -95,7 +95,8 @@ ASRC = ../../ports/ARM7-AT91SAM7X/chcore.c \
TSRC =
# List ASM source files here
-ASMSRC = ../../ports/ARM7-AT91SAM7X/crt0.s ../../ports/ARM7/chsys.s
+ASMSRC = ../../ports/ARM7/crt0.s ../../ports/ARM7/chsys.s \
+ ../../ports/ARM7-AT91SAM7X/vectors.s
# List all user directories here
UINCDIR = ../../src/include ../../src/lib ../../test \
diff --git a/demos/ARM7-AT91SAM7X-WEB-GCC/Makefile.thumb b/demos/ARM7-AT91SAM7X-WEB-GCC/Makefile.thumb
index 0b5c72349..2ef54fb5d 100644
--- a/demos/ARM7-AT91SAM7X-WEB-GCC/Makefile.thumb
+++ b/demos/ARM7-AT91SAM7X-WEB-GCC/Makefile.thumb
@@ -96,7 +96,8 @@ TSRC = ../../ports/ARM7-AT91SAM7X/chcore.c \
board.c main.c
# List ASM source files here
-ASMSRC = ../../ports/ARM7-AT91SAM7X/crt0.s ../../ports/ARM7/chsys.s
+ASMSRC = ../../ports/ARM7/crt0.s ../../ports/ARM7/chsys.s \
+ ../../ports/ARM7-AT91SAM7X/vectors.s
# List all user directories here
UINCDIR = ../../src/include ../../src/lib ../../test \
diff --git a/demos/ARM7-AT91SAM7X-WEB-GCC/ch.ld b/demos/ARM7-AT91SAM7X-WEB-GCC/ch.ld
index 7459bdac1..89a2c2f2b 100644
--- a/demos/ARM7-AT91SAM7X-WEB-GCC/ch.ld
+++ b/demos/ARM7-AT91SAM7X-WEB-GCC/ch.ld
@@ -45,7 +45,7 @@ SECTIONS
.text :
{
_text = .;
- KEEP(*(.startup))
+ KEEP(*(vectors));
*(.text)
*(.text.*);
*(.rodata);