diff options
Diffstat (limited to 'demos')
-rw-r--r-- | demos/ARM7-LPC214x-GCC-minimal/Makefile | 12 | ||||
-rw-r--r-- | demos/ARM7-LPC214x-GCC-minimal/Makefile.thumb | 14 | ||||
-rw-r--r-- | demos/ARM7-LPC214x-GCC/Makefile | 14 | ||||
-rw-r--r-- | demos/ARM7-LPC214x-GCC/Makefile.thumb | 14 |
4 files changed, 27 insertions, 27 deletions
diff --git a/demos/ARM7-LPC214x-GCC-minimal/Makefile b/demos/ARM7-LPC214x-GCC-minimal/Makefile index 3514a9090..1fe22d71a 100644 --- a/demos/ARM7-LPC214x-GCC-minimal/Makefile +++ b/demos/ARM7-LPC214x-GCC-minimal/Makefile @@ -127,16 +127,16 @@ ODFLAGS = -x --syms # Thumb interwork enabled only if needed because it kills performance.
ifneq ($(TSRC),)
+ CPFLAGS += -D THUMB_PRESENT
ifneq ($(ASRC),)
- # Both ARM and THUMB case
- CPFLAGS += -mthumb-interwork -D THUMB
+ # Mixed ARM and THUMB case.
+ CPFLAGS += -mthumb-interwork
LDFLAGS += -mthumb-interwork
- ASFLAGS += -mthumb-interwork -D THUMB
else
- # Pure THUMB case, THUMB C code cannot be called by ARM asm code directly
- CPFLAGS += -D THUMB
+ # Pure THUMB case, THUMB C code cannot be called by ARM asm code directly.
+ CPFLAGS += -D THUMB_NO_INTERWORKING
LDFLAGS += -mthumb
- ASFLAGS += -mthumb-interwork -D THUMB -D THUMB_NO_INTERWORKING
+ ASFLAGS += -D THUMB_NO_INTERWORKING
endif
endif
diff --git a/demos/ARM7-LPC214x-GCC-minimal/Makefile.thumb b/demos/ARM7-LPC214x-GCC-minimal/Makefile.thumb index 76b3fd296..b00adef75 100644 --- a/demos/ARM7-LPC214x-GCC-minimal/Makefile.thumb +++ b/demos/ARM7-LPC214x-GCC-minimal/Makefile.thumb @@ -91,7 +91,7 @@ ULIBS = AOPT =
# THUMB-specific options here
-TOPT = -mthumb
+TOPT = -mthumb -D THUMB
# Common options here
# NOTE: -ffixed-r7 is only needed if you enabled CH_CURRP_REGISTER_CACHE in
@@ -127,16 +127,16 @@ ODFLAGS = -x --syms # Thumb interwork enabled only if needed because it kills performance.
ifneq ($(TSRC),)
+ CPFLAGS += -D THUMB_PRESENT
ifneq ($(ASRC),)
- # Both ARM and THUMB case
- CPFLAGS += -mthumb-interwork -D THUMB
+ # Mixed ARM and THUMB case.
+ CPFLAGS += -mthumb-interwork
LDFLAGS += -mthumb-interwork
- ASFLAGS += -mthumb-interwork -D THUMB
else
- # Pure THUMB case, THUMB C code cannot be called by ARM asm code directly
- CPFLAGS += -D THUMB -D THUMB_NO_INTERWORKING
+ # Pure THUMB case, THUMB C code cannot be called by ARM asm code directly.
+ CPFLAGS += -D THUMB_NO_INTERWORKING
LDFLAGS += -mthumb
- ASFLAGS += -mthumb-interwork -D THUMB -D THUMB_NO_INTERWORKING
+ ASFLAGS += -D THUMB_NO_INTERWORKING
endif
endif
diff --git a/demos/ARM7-LPC214x-GCC/Makefile b/demos/ARM7-LPC214x-GCC/Makefile index 13c32b4dc..5e49defda 100644 --- a/demos/ARM7-LPC214x-GCC/Makefile +++ b/demos/ARM7-LPC214x-GCC/Makefile @@ -130,16 +130,16 @@ ODFLAGS = -x --syms # Thumb interwork enabled only if needed because it kills performance.
ifneq ($(TSRC),)
+ CPFLAGS += -D THUMB_PRESENT
ifneq ($(ASRC),)
- # Both ARM and THUMB case
- CPFLAGS += -mthumb-interwork -D THUMB
+ # Mixed ARM and THUMB case.
+ CPFLAGS += -mthumb-interwork
LDFLAGS += -mthumb-interwork
- ASFLAGS += -mthumb-interwork -D THUMB
else
- # Pure THUMB case, THUMB C code cannot be called by ARM asm code directly
- CPFLAGS += -D THUMB
+ # Pure THUMB case, THUMB C code cannot be called by ARM asm code directly.
+ CPFLAGS += -D THUMB_NO_INTERWORKING
LDFLAGS += -mthumb
- ASFLAGS += -mthumb-interwork -D THUMB -D THUMB_NO_INTERWORKING
+ ASFLAGS += -D THUMB_NO_INTERWORKING
endif
endif
@@ -158,7 +158,7 @@ $(AOBJS) : %.o : %.c $(TOBJS) : %.o : %.c
@echo
- $(CC) -c $(CPFLAGS) $(TOPT) -mthumb -I . $(INCDIR) $< -o $@
+ $(CC) -c $(CPFLAGS) $(TOPT) -I . $(INCDIR) $< -o $@
$(ASMOBJS) : %.o : %.s
@echo
diff --git a/demos/ARM7-LPC214x-GCC/Makefile.thumb b/demos/ARM7-LPC214x-GCC/Makefile.thumb index 93188a528..89ccdfdc2 100644 --- a/demos/ARM7-LPC214x-GCC/Makefile.thumb +++ b/demos/ARM7-LPC214x-GCC/Makefile.thumb @@ -94,7 +94,7 @@ ULIBS = AOPT =
# THUMB-specific options here
-TOPT = -mthumb
+TOPT = -mthumb -D THUMB
# Common options here
# NOTE: -ffixed-r7 is only needed if you enabled CH_CURRP_REGISTER_CACHE in
@@ -130,16 +130,16 @@ ODFLAGS = -x --syms # Thumb interwork enabled only if needed because it kills performance.
ifneq ($(TSRC),)
+ CPFLAGS += -D THUMB_PRESENT
ifneq ($(ASRC),)
- # Both ARM and THUMB case
- CPFLAGS += -mthumb-interwork -D THUMB
+ # Mixed ARM and THUMB case.
+ CPFLAGS += -mthumb-interwork
LDFLAGS += -mthumb-interwork
- ASFLAGS += -mthumb-interwork -D THUMB
else
- # Pure THUMB case, THUMB C code cannot be called by ARM asm code directly
- CPFLAGS += -D THUMB -D THUMB_NO_INTERWORKING
+ # Pure THUMB case, THUMB C code cannot be called by ARM asm code directly.
+ CPFLAGS += -D THUMB_NO_INTERWORKING
LDFLAGS += -mthumb
- ASFLAGS += -mthumb-interwork -D THUMB -D THUMB_NO_INTERWORKING
+ ASFLAGS += -D THUMB_NO_INTERWORKING
endif
endif
|