aboutsummaryrefslogtreecommitdiffstats
path: root/demos
diff options
context:
space:
mode:
Diffstat (limited to 'demos')
-rw-r--r--demos/ARMCM4-STM32F303-DISCOVERY/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/demos/ARMCM4-STM32F303-DISCOVERY/Makefile b/demos/ARMCM4-STM32F303-DISCOVERY/Makefile
index b5bec63e4..4f37ba911 100644
--- a/demos/ARMCM4-STM32F303-DISCOVERY/Makefile
+++ b/demos/ARMCM4-STM32F303-DISCOVERY/Makefile
@@ -69,8 +69,8 @@ include $(CHIBIOS)/boards/ST_STM32F3_DISCOVERY/board.mk
include $(CHIBIOS)/os/halnew/hal.mk
include $(CHIBIOS)/os/halnew/osal/chibios/osal.mk
include $(CHIBIOS)/os/halnew/platforms/STM32F30x/platform.mk
-include $(CHIBIOS)/os/ports/GCC/ARMCMx/STM32F3xx/port.mk
include $(CHIBIOS)/os/kernel/kernel.mk
+include $(CHIBIOS)/os/kernel/ports/ARMCMx/devices/STM32F30x/port.mk
include $(CHIBIOS)/test/test.mk
# Define linker script file here
@@ -209,8 +209,10 @@ ULIBS =
ifeq ($(USE_FPU),yes)
USE_OPT += -mfloat-abi=softfp -mfpu=fpv4-sp-d16 -fsingle-precision-constant
DDEFS += -DCORTEX_USE_FPU=TRUE
+ DADEFS += -DCORTEX_USE_FPU=TRUE
else
DDEFS += -DCORTEX_USE_FPU=FALSE
+ DADEFS += -DCORTEX_USE_FPU=FALSE
endif
ifeq ($(USE_FWLIB),yes)
@@ -220,4 +222,4 @@ ifeq ($(USE_FWLIB),yes)
USE_OPT += -DUSE_STDPERIPH_DRIVER
endif
-include $(CHIBIOS)/os/ports/GCC/ARMCMx/rules.mk
+include $(CHIBIOS)/os/kernel/ports/ARMCMx/compilers/GCC/rules.mk