diff options
Diffstat (limited to 'demos')
-rw-r--r-- | demos/ARMCM4-STM32F407-DISCOVERY-MEMS-G++/Makefile | 5 |
1 files changed, 4 insertions, 1 deletions
diff --git a/demos/ARMCM4-STM32F407-DISCOVERY-MEMS-G++/Makefile b/demos/ARMCM4-STM32F407-DISCOVERY-MEMS-G++/Makefile index dbbed56cd..80c926465 100644 --- a/demos/ARMCM4-STM32F407-DISCOVERY-MEMS-G++/Makefile +++ b/demos/ARMCM4-STM32F407-DISCOVERY-MEMS-G++/Makefile @@ -70,6 +70,7 @@ include $(CHIBIOS)/os/hal/platforms/STM32F4xx/platform.mk include $(CHIBIOS)/os/hal/hal.mk
include $(CHIBIOS)/os/ports/GCC/ARMCMx/STM32F4xx/port.mk
include $(CHIBIOS)/os/kernel/kernel.mk
+include $(CHIBIOS)/os/various/cpp_wrappers/kernel.mk
include $(CHIBIOS)/test/test.mk
# Define linker script file here
@@ -92,7 +93,8 @@ CSRC = $(PORTSRC) \ # C++ sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
-CPPSRC = $(CHIBIOS)/os/various/ch.cpp main.cpp
+CPPSRC = $(CHCPPSRC) \
+ main.cpp
# C sources to be compiled in ARM mode regardless of the global setting.
# NOTE: Mixing ARM and THUMB mode enables the -mthumb-interwork compiler
@@ -119,6 +121,7 @@ ASMSRC = $(PORTASM) INCDIR = $(PORTINC) $(KERNINC) $(TESTINC) \
$(HALINC) $(PLATFORMINC) $(BOARDINC) \
+ $(CHCPPINC) \
$(CHIBIOS)/os/various/devices_lib/accel \
$(CHIBIOS)/os/various
|