aboutsummaryrefslogtreecommitdiffstats
path: root/demos
diff options
context:
space:
mode:
Diffstat (limited to 'demos')
-rw-r--r--demos/ARM7-LPC214x-GCC-minimal/Makefile12
-rw-r--r--demos/ARM7-LPC214x-GCC-minimal/Makefile.thumb10
-rw-r--r--demos/ARM7-LPC214x-GCC/Makefile2
-rw-r--r--demos/ARM7-LPC214x-GCC/Makefile.thumb2
-rw-r--r--demos/ARM7-LPC214x-GCC/board.c2
5 files changed, 17 insertions, 11 deletions
diff --git a/demos/ARM7-LPC214x-GCC-minimal/Makefile b/demos/ARM7-LPC214x-GCC-minimal/Makefile
index 1fe22d71a..d8ed9ed9b 100644
--- a/demos/ARM7-LPC214x-GCC-minimal/Makefile
+++ b/demos/ARM7-LPC214x-GCC-minimal/Makefile
@@ -62,8 +62,8 @@ UDEFS =
UADEFS =
# List ARM-mode C source files here
-ASRC = ../../ports/ARM7-LPC214x/GCC/chcore.c \
- ../../ports/ARM7-LPC214x/GCC/vic.c \
+ASRC = ../../ports/ARM7-LPC214x/chcore.c \
+ ../../ports/ARM7-LPC214x/vic.c \
../../src/chinit.c ../../src/chdebug.c ../../src/chlists.c ../../src/chdelta.c \
../../src/chschd.c ../../src/chthreads.c ../../src/chsem.c ../../src/chmtx.c \
../../src/chevents.c ../../src/chmsg.c ../../src/chsleep.c ../../src/chqueues.c \
@@ -76,10 +76,11 @@ ASRC = ../../ports/ARM7-LPC214x/GCC/chcore.c \
TSRC =
# List ASM source files here
-ASMSRC = ../../ports/ARM7-LPC214x/GCC/crt0.s
+ASMSRC = ../../ports/ARM7-LPC214x/crt0.s ../../ports/ARM7/chsys.s
# List all user directories here
-UINCDIR = ../../src/include ../../src/lib ../../ports/ARM7-LPC214x/GCC
+UINCDIR = ../../src/include ../../src/lib \
+ ../../ports/ARM7 ../../ports/ARM7-LPC214x
# List the user directory to look for the libraries here
ULIBDIR =
@@ -128,6 +129,7 @@ ODFLAGS = -x --syms
# Thumb interwork enabled only if needed because it kills performance.
ifneq ($(TSRC),)
CPFLAGS += -D THUMB_PRESENT
+ ASFLAGS += -D THUMB_PRESENT
ifneq ($(ASRC),)
# Mixed ARM and THUMB case.
CPFLAGS += -mthumb-interwork
@@ -155,7 +157,7 @@ $(AOBJS) : %.o : %.c
$(TOBJS) : %.o : %.c
@echo
- $(CC) -c $(CPFLAGS) $(TOPT) -mthumb -I . $(INCDIR) $< -o $@
+ $(CC) -c $(CPFLAGS) $(TOPT) -I . $(INCDIR) $< -o $@
$(ASMOBJS) : %.o : %.s
@echo
diff --git a/demos/ARM7-LPC214x-GCC-minimal/Makefile.thumb b/demos/ARM7-LPC214x-GCC-minimal/Makefile.thumb
index b00adef75..621e71853 100644
--- a/demos/ARM7-LPC214x-GCC-minimal/Makefile.thumb
+++ b/demos/ARM7-LPC214x-GCC-minimal/Makefile.thumb
@@ -67,8 +67,8 @@ ASRC =
# List THUMB-mode C sources here
# NOTE: If any module is compiled in thumb mode then -mthumb-interwork is
# enabled for all modules and that lowers performance.
-TSRC = ../../ports/ARM7-LPC214x/GCC/chcore.c \
- ../../ports/ARM7-LPC214x/GCC/vic.c \
+TSRC = ../../ports/ARM7-LPC214x/chcore.c \
+ ../../ports/ARM7-LPC214x/vic.c \
../../src/chinit.c ../../src/chdebug.c ../../src/chlists.c ../../src/chdelta.c \
../../src/chschd.c ../../src/chthreads.c ../../src/chsem.c ../../src/chmtx.c \
../../src/chevents.c ../../src/chmsg.c ../../src/chsleep.c ../../src/chqueues.c \
@@ -76,10 +76,11 @@ TSRC = ../../ports/ARM7-LPC214x/GCC/chcore.c \
board.c main.c
# List ASM source files here
-ASMSRC = ../../ports/ARM7-LPC214x/GCC/crt0.s
+ASMSRC = ../../ports/ARM7-LPC214x/crt0.s ../../ports/ARM7/chsys.s
# List all user directories here
-UINCDIR = ../../src/include ../../src/lib ../../ports/ARM7-LPC214x/GCC
+UINCDIR = ../../src/include ../../src/lib \
+ ../../ports/ARM7 ../../ports/ARM7-LPC214x
# List the user directory to look for the libraries here
ULIBDIR =
@@ -128,6 +129,7 @@ ODFLAGS = -x --syms
# Thumb interwork enabled only if needed because it kills performance.
ifneq ($(TSRC),)
CPFLAGS += -D THUMB_PRESENT
+ ASFLAGS += -D THUMB_PRESENT
ifneq ($(ASRC),)
# Mixed ARM and THUMB case.
CPFLAGS += -mthumb-interwork
diff --git a/demos/ARM7-LPC214x-GCC/Makefile b/demos/ARM7-LPC214x-GCC/Makefile
index c7177b094..5168f764a 100644
--- a/demos/ARM7-LPC214x-GCC/Makefile
+++ b/demos/ARM7-LPC214x-GCC/Makefile
@@ -79,7 +79,7 @@ ASRC = ../../ports/ARM7-LPC214x/chcore.c \
TSRC =
# List ASM source files here
-ASMSRC = ../../ports/ARM7-LPC214x/crt0.s
+ASMSRC = ../../ports/ARM7-LPC214x/crt0.s ../../ports/ARM7/chsys.s
# List all user directories here
UINCDIR = ../../src/include ../../src/lib \
diff --git a/demos/ARM7-LPC214x-GCC/Makefile.thumb b/demos/ARM7-LPC214x-GCC/Makefile.thumb
index 66d799ad9..a8840a293 100644
--- a/demos/ARM7-LPC214x-GCC/Makefile.thumb
+++ b/demos/ARM7-LPC214x-GCC/Makefile.thumb
@@ -79,7 +79,7 @@ TSRC = ../../ports/ARM7-LPC214x/chcore.c \
board.c buzzer.c mmcsd.c main.c
# List ASM source files here
-ASMSRC = ../../ports/ARM7-LPC214x/crt0.s
+ASMSRC = ../../ports/ARM7-LPC214x/crt0.s ../../ports/ARM7/chsys.s
# List all user directories here
UINCDIR = ../../src/include ../../src/lib \
diff --git a/demos/ARM7-LPC214x-GCC/board.c b/demos/ARM7-LPC214x-GCC/board.c
index 23e642f01..94bc21336 100644
--- a/demos/ARM7-LPC214x-GCC/board.c
+++ b/demos/ARM7-LPC214x-GCC/board.c
@@ -37,6 +37,7 @@ static void IrqHandler(void) {
chSysIRQEnterI();
/* nothing */
+ VICVectAddr = 0;
chSysIRQExitI();
}
@@ -51,6 +52,7 @@ static void T0IrqHandler(void) {
T0IR = 1; /* Clear interrupt on match MR0. */
chSysTimerHandlerI();
+ VICVectAddr = 0;
chSysIRQExitI();
}