diff options
Diffstat (limited to 'os/hal/templates')
-rw-r--r-- | os/hal/templates/board/board.c | 24 | ||||
-rw-r--r-- | os/hal/templates/board/board.h | 40 | ||||
-rw-r--r-- | os/hal/templates/board/board.mk | 5 | ||||
-rw-r--r-- | os/hal/templates/hal_i2s_lld.c | 1 | ||||
-rw-r--r-- | os/hal/templates/hal_wdg_lld.c | 5 | ||||
-rw-r--r-- | os/hal/templates/platform.mk | 20 |
6 files changed, 74 insertions, 21 deletions
diff --git a/os/hal/templates/board/board.c b/os/hal/templates/board/board.c new file mode 100644 index 000000000..967202992 --- /dev/null +++ b/os/hal/templates/board/board.c @@ -0,0 +1,24 @@ +/*
+ ChibiOS - Copyright (C) 2006..2016 Giovanni Di Sirio
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+*/
+
+#include "hal.h"
+
+/**
+ * @brief Board-specific initialization code.
+ * @todo Add your board-specific code, if any.
+ */
+void boardInit(void) {
+}
diff --git a/os/hal/templates/board/board.h b/os/hal/templates/board/board.h new file mode 100644 index 000000000..408cbb918 --- /dev/null +++ b/os/hal/templates/board/board.h @@ -0,0 +1,40 @@ +/*
+ ChibiOS - Copyright (C) 2006..2016 Giovanni Di Sirio
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+*/
+
+#ifndef BOARD_H
+#define BOARD_H
+
+/*
+ * Setup for a generic board.
+ */
+
+/*
+ * Board identifier.
+ */
+#define BOARD_GENERIC
+#define BOARD_NAME "Generic Board"
+
+#if !defined(_FROM_ASM_)
+#ifdef __cplusplus
+extern "C" {
+#endif
+ void boardInit(void);
+#ifdef __cplusplus
+}
+#endif
+#endif /* _FROM_ASM_ */
+
+#endif /* BOARD_H */
diff --git a/os/hal/templates/board/board.mk b/os/hal/templates/board/board.mk new file mode 100644 index 000000000..a8506ee07 --- /dev/null +++ b/os/hal/templates/board/board.mk @@ -0,0 +1,5 @@ +# List of all the board related files.
+BOARDSRC = $(CHIBIOS)/os/hal/templates/board/board.c
+
+# Required include directories
+BOARDINC = $(CHIBIOS)/os/hal/templates/board
diff --git a/os/hal/templates/hal_i2s_lld.c b/os/hal/templates/hal_i2s_lld.c index 3a77b2636..7424a663a 100644 --- a/os/hal/templates/hal_i2s_lld.c +++ b/os/hal/templates/hal_i2s_lld.c @@ -84,6 +84,7 @@ void i2s_lld_start(I2SDriver *i2sp) { }
#endif
+ }
}
/**
diff --git a/os/hal/templates/hal_wdg_lld.c b/os/hal/templates/hal_wdg_lld.c index 603379684..b446a30d5 100644 --- a/os/hal/templates/hal_wdg_lld.c +++ b/os/hal/templates/hal_wdg_lld.c @@ -34,7 +34,7 @@ /* Driver exported variables. */
/*===========================================================================*/
-#if STM32_WDG_USE_WDG1 || defined(__DOXYGEN__)
+#if PLATFORM_WDG_USE_WDG1 || defined(__DOXYGEN__)
WDGDriver WDGD1;
#endif
@@ -72,6 +72,7 @@ void wdg_lld_init(void) { */
void wdg_lld_start(WDGDriver *wdgp) {
+ (void)wdgp;
}
/**
@@ -83,6 +84,7 @@ void wdg_lld_start(WDGDriver *wdgp) { */
void wdg_lld_stop(WDGDriver *wdgp) {
+ (void)wdgp;
}
/**
@@ -94,6 +96,7 @@ void wdg_lld_stop(WDGDriver *wdgp) { */
void wdg_lld_reset(WDGDriver * wdgp) {
+ (void)wdgp;
}
#endif /* HAL_USE_WDG */
diff --git a/os/hal/templates/platform.mk b/os/hal/templates/platform.mk deleted file mode 100644 index a5fbb1065..000000000 --- a/os/hal/templates/platform.mk +++ /dev/null @@ -1,20 +0,0 @@ -# List of all the template platform files.
-PLATFORMSRC = ${CHIBIOS}/os/hal/templates/hal_lld.c \
- ${CHIBIOS}/os/hal/templates/hal_adc_lld.c \
- ${CHIBIOS}/os/hal/templates/hal_can_lld.c \
- ${CHIBIOS}/os/hal/templates/hal_dac_lld.c \
- ${CHIBIOS}/os/hal/templates/hal_ext_lld.c \
- ${CHIBIOS}/os/hal/templates/hal_gpt_lld.c \
- ${CHIBIOS}/os/hal/templates/hal_i2c_lld.c \
- ${CHIBIOS}/os/hal/templates/hal_icu_lld.c \
- ${CHIBIOS}/os/hal/templates/hal_mac_lld.c \
- ${CHIBIOS}/os/hal/templates/hal_pal_lld.c \
- ${CHIBIOS}/os/hal/templates/hal_pwm_lld.c \
- ${CHIBIOS}/os/hal/templates/hal_sdc_lld.c \
- ${CHIBIOS}/os/hal/templates/hal_serial_lld.c \
- ${CHIBIOS}/os/hal/templates/hal_spi_lld.c \
- ${CHIBIOS}/os/hal/templates/hal_uart_lld.c \
- ${CHIBIOS}/os/hal/templates/hal_usb_lld.c
-
-# Required include directories
-PLATFORMINC = ${CHIBIOS}/os/hal/templates
|