aboutsummaryrefslogtreecommitdiffstats
path: root/test/oslib/oslib_test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'test/oslib/oslib_test.mk')
-rw-r--r--test/oslib/oslib_test.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/test/oslib/oslib_test.mk b/test/oslib/oslib_test.mk
new file mode 100644
index 000000000..f342719e1
--- /dev/null
+++ b/test/oslib/oslib_test.mk
@@ -0,0 +1,9 @@
+# List of all the ChibiOS OS Library test files.
+TESTSRC += ${CHIBIOS}/test/oslib/source/test/oslib_test_root.c \
+ ${CHIBIOS}/test/oslib/source/test/oslib_test_sequence_001.c \
+ ${CHIBIOS}/test/oslib/source/test/oslib_test_sequence_002.c \
+ ${CHIBIOS}/test/oslib/source/test/oslib_test_sequence_003.c \
+ ${CHIBIOS}/test/oslib/source/test/oslib_test_sequence_004.c
+
+# Required include directories
+TESTINC += ${CHIBIOS}/test/oslib/source/test