diff options
Diffstat (limited to 'test')
-rw-r--r-- | test/test.c | 8 | ||||
-rw-r--r-- | test/test.mk | 5 | ||||
-rw-r--r-- | test/testsem.c | 4 |
3 files changed, 15 insertions, 2 deletions
diff --git a/test/test.c b/test/test.c index 667b89749..9a1af1725 100644 --- a/test/test.c +++ b/test/test.c @@ -24,6 +24,7 @@ #include "testsem.h"
#include "testmtx.h"
#include "testmsg.h"
+#include "testevt.h"
#include "testheap.h"
#include "testpools.h"
#include "testdyn.h"
@@ -35,14 +36,21 @@ static const struct testcase *tests[] = {
&testrdy1,
&testrdy2,
+#ifdef CH_USE_SEMAPHORES
&testsem1,
&testsem2,
+#endif
#ifdef CH_USE_MUTEXES
&testmtx1,
&testmtx2,
&testmtx3,
#endif
+#ifdef CH_USE_MESSAGES
&testmsg1,
+#endif
+#ifdef CH_USE_EVENTS
+ &testevt1,
+#endif
#ifdef CH_USE_HEAP
&testheap1,
#endif
diff --git a/test/test.mk b/test/test.mk index 9ea33e412..e65db3345 100644 --- a/test/test.mk +++ b/test/test.mk @@ -1,4 +1,5 @@ # List of all the ChibiOS/RT test files.
TESTSRC = ../../test/test.c ../../test/testrdy.c ../../test/testsem.c \
- ../../test/testmtx.c ../../test/testmsg.c ../../test/testheap.c \
- ../../test/testpools.c ../../test/testdyn.c ../../test/testbmk.c
+ ../../test/testmtx.c ../../test/testmsg.c ../../test/testevt.c \
+ ../../test/testheap.c ../../test/testpools.c ../../test/testdyn.c \
+ ../../test/testbmk.c
diff --git a/test/testsem.c b/test/testsem.c index f2105a7dd..26c5556f5 100644 --- a/test/testsem.c +++ b/test/testsem.c @@ -21,6 +21,8 @@ #include "test.h"
+#ifdef CH_USE_SEMAPHORES
+
#define ALLOWED_DELAY MS2ST(5)
static Semaphore sem1;
@@ -100,3 +102,5 @@ const struct testcase testsem2 = { sem2_teardown,
sem2_execute
};
+
+#endif /* CH_USE_SEMAPHORES */
|