aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/ATSAMA5D2/FLEX-SPI
diff options
context:
space:
mode:
Diffstat (limited to 'testhal/ATSAMA5D2/FLEX-SPI')
-rw-r--r--testhal/ATSAMA5D2/FLEX-SPI/Makefile25
-rw-r--r--testhal/ATSAMA5D2/FLEX-SPI/debug/SAMA5D2-FLEX-SPI (DDRAM).launch2
-rw-r--r--testhal/ATSAMA5D2/FLEX-SPI/readme.txt2
3 files changed, 12 insertions, 17 deletions
diff --git a/testhal/ATSAMA5D2/FLEX-SPI/Makefile b/testhal/ATSAMA5D2/FLEX-SPI/Makefile
index d80992791..f95aec96a 100644
--- a/testhal/ATSAMA5D2/FLEX-SPI/Makefile
+++ b/testhal/ATSAMA5D2/FLEX-SPI/Makefile
@@ -108,9 +108,14 @@ endif
# Define project name here
PROJECT = ch
+BUILDDIR := ./build
+DEPDIR := ./.dep
# Imported source files and paths
CHIBIOS = ../../..
+
+# Licensing files.
+include $(CHIBIOS)/os/license/license.mk
# Startup files.
include $(CHIBIOS)/os/common/startup/ARMCAx-TZ/compilers/GCC/mk/startup_sama5d2.mk
# HAL-OSAL files (optional).
@@ -133,19 +138,12 @@ LDSCRIPT= $(STARTUPLD)/SAMA5D2ddr.ld
# C sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
-CSRC = $(STARTUPSRC) \
- $(KERNSRC) \
- $(PORTSRC) \
- $(OSALSRC) \
- $(HALSRC) \
- $(PLATFORMSRC) \
- $(BOARDSRC) \
- $(TESTSRC) \
+CSRC = $(ALLCSRC) \
main.c
# C++ sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
-CPPSRC =
+CPPSRC = $(ALLCPPSRC)
# C sources to be compiled in ARM mode regardless of the global setting.
# NOTE: Mixing ARM and THUMB mode enables the -mthumb-interwork compiler
@@ -168,13 +166,10 @@ TCSRC =
TCPPSRC =
# List ASM source files here
-ASMSRC =
-ASMXSRC = $(STARTUPASM) $(PORTASM) $(OSALASM)
+ASMSRC = $(ALLASMSRC)
+ASMXSRC = $(ALLXASMSRC)
-INCDIR = $(CHIBIOS)/os/license \
- $(STARTUPINC) $(KERNINC) $(PORTINC) $(OSALINC) \
- $(HALINC) $(PLATFORMINC) $(BOARDINC) $(TESTINC) \
- $(CHIBIOS)/os/various
+INCDIR = $(ALLINC)
#
# Project, sources and paths
diff --git a/testhal/ATSAMA5D2/FLEX-SPI/debug/SAMA5D2-FLEX-SPI (DDRAM).launch b/testhal/ATSAMA5D2/FLEX-SPI/debug/SAMA5D2-FLEX-SPI (DDRAM).launch
index d937e70b0..904e11d17 100644
--- a/testhal/ATSAMA5D2/FLEX-SPI/debug/SAMA5D2-FLEX-SPI (DDRAM).launch
+++ b/testhal/ATSAMA5D2/FLEX-SPI/debug/SAMA5D2-FLEX-SPI (DDRAM).launch
@@ -11,7 +11,7 @@
<stringAttribute key="org.eclipse.cdt.debug.gdbjtag.core.jtagDevice" value="Generic TCP/IP"/>
<booleanAttribute key="org.eclipse.cdt.debug.gdbjtag.core.loadImage" value="true"/>
<booleanAttribute key="org.eclipse.cdt.debug.gdbjtag.core.loadSymbols" value="true"/>
-<stringAttribute key="org.eclipse.cdt.debug.gdbjtag.core.pcRegister" value="20100000"/>
+<stringAttribute key="org.eclipse.cdt.debug.gdbjtag.core.pcRegister" value="27000000"/>
<intAttribute key="org.eclipse.cdt.debug.gdbjtag.core.portNumber" value="2331"/>
<stringAttribute key="org.eclipse.cdt.debug.gdbjtag.core.runCommands" value=""/>
<booleanAttribute key="org.eclipse.cdt.debug.gdbjtag.core.setPcRegister" value="true"/>
diff --git a/testhal/ATSAMA5D2/FLEX-SPI/readme.txt b/testhal/ATSAMA5D2/FLEX-SPI/readme.txt
index cc6e568f6..303da320d 100644
--- a/testhal/ATSAMA5D2/FLEX-SPI/readme.txt
+++ b/testhal/ATSAMA5D2/FLEX-SPI/readme.txt
@@ -4,7 +4,7 @@
** TARGET **
-The demo targets a generic ARM Cortex-A5 device without HAL support.
+The demo runs on an SAMA5D2-XPLAINED board.
** The Demo **