diff options
Diffstat (limited to 'testhal/ATSAMA5D2/MATRIX')
-rwxr-xr-x | testhal/ATSAMA5D2/MATRIX/Makefile | 25 | ||||
-rwxr-xr-x | testhal/ATSAMA5D2/MATRIX/readme.txt | 2 |
2 files changed, 11 insertions, 16 deletions
diff --git a/testhal/ATSAMA5D2/MATRIX/Makefile b/testhal/ATSAMA5D2/MATRIX/Makefile index 797a1585c..0372c07ed 100755 --- a/testhal/ATSAMA5D2/MATRIX/Makefile +++ b/testhal/ATSAMA5D2/MATRIX/Makefile @@ -108,9 +108,14 @@ endif # Define project name here
PROJECT = ch
+BUILDDIR := ./build
+DEPDIR := ./.dep
# Imported source files and paths
CHIBIOS = ../../..
+
+# Licensing files.
+include $(CHIBIOS)/os/license/license.mk
# Startup files.
include $(CHIBIOS)/os/common/startup/ARMCAx-TZ/compilers/GCC/mk/startup_sama5d2.mk
# HAL-OSAL files (optional).
@@ -132,19 +137,12 @@ LDSCRIPT= $(STARTUPLD)/SAMA5D2ddr.ld # C sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
-CSRC = $(STARTUPSRC) \
- $(KERNSRC) \
- $(PORTSRC) \
- $(OSALSRC) \
- $(HALSRC) \
- $(PLATFORMSRC) \
- $(BOARDSRC) \
- $(TESTSRC) \
+CSRC = $(ALLCSRC) \
main.c
# C++ sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
-CPPSRC =
+CPPSRC = $(ALLCPPSRC)
# C sources to be compiled in ARM mode regardless of the global setting.
# NOTE: Mixing ARM and THUMB mode enables the -mthumb-interwork compiler
@@ -167,13 +165,10 @@ TCSRC = TCPPSRC =
# List ASM source files here
-ASMSRC =
-ASMXSRC = $(STARTUPASM) $(PORTASM) $(OSALASM)
+ASMSRC = $(ALLASMSRC)
+ASMXSRC = $(ALLXASMSRC)
-INCDIR = $(CHIBIOS)/os/license \
- $(STARTUPINC) $(KERNINC) $(PORTINC) $(OSALINC) \
- $(HALINC) $(PLATFORMINC) $(BOARDINC) $(TESTINC) \
- $(CHIBIOS)/os/various
+INCDIR = $(ALLINC)
#
# Project, sources and paths
diff --git a/testhal/ATSAMA5D2/MATRIX/readme.txt b/testhal/ATSAMA5D2/MATRIX/readme.txt index 54fbf102d..4cad2f6fb 100755 --- a/testhal/ATSAMA5D2/MATRIX/readme.txt +++ b/testhal/ATSAMA5D2/MATRIX/readme.txt @@ -4,7 +4,7 @@ ** TARGET **
-The demo targets a generic ARM Cortex-A5 device without HAL support.
+The demo runs on an SAMA5D2-XPLAINED board.
** The Demo **
Demo configures security zone on SRAM0. Zones are tested with two writing
|