aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/STM32/STM32F0xx/CAN
diff options
context:
space:
mode:
Diffstat (limited to 'testhal/STM32/STM32F0xx/CAN')
-rw-r--r--testhal/STM32/STM32F0xx/CAN/Makefile4
-rw-r--r--testhal/STM32/STM32F0xx/CAN/main.c4
2 files changed, 4 insertions, 4 deletions
diff --git a/testhal/STM32/STM32F0xx/CAN/Makefile b/testhal/STM32/STM32F0xx/CAN/Makefile
index 158e8e5ff..c5a247274 100644
--- a/testhal/STM32/STM32F0xx/CAN/Makefile
+++ b/testhal/STM32/STM32F0xx/CAN/Makefile
@@ -94,8 +94,8 @@ include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/port_v6m.mk
# Other files (optional).
#include $(CHIBIOS)/test/lib/test.mk
-include $(CHIBIOS)/test/rt/rt_test.mk
-include $(CHIBIOS)/test/oslib/oslib_test.mk
+#include $(CHIBIOS)/test/rt/rt_test.mk
+#include $(CHIBIOS)/test/oslib/oslib_test.mk
# Define linker script file here
LDSCRIPT= $(STARTUPLD)/STM32F072xB.ld
diff --git a/testhal/STM32/STM32F0xx/CAN/main.c b/testhal/STM32/STM32F0xx/CAN/main.c
index cae08f4e7..691b64655 100644
--- a/testhal/STM32/STM32F0xx/CAN/main.c
+++ b/testhal/STM32/STM32F0xx/CAN/main.c
@@ -39,7 +39,7 @@ static THD_FUNCTION(can_rx, p) {
chRegSetThreadName("receiver");
chEvtRegister(&CAND1.rxfull_event, &el, 0);
while (true) {
- if (chEvtWaitAnyTimeout(ALL_EVENTS, MS2ST(100)) == 0)
+ if (chEvtWaitAnyTimeout(ALL_EVENTS, TIME_MS2I(100)) == 0)
continue;
while (canReceive(&CAND1, CAN_ANY_MAILBOX, &rxmsg, TIME_IMMEDIATE) == MSG_OK) {
/* Process message.*/
@@ -66,7 +66,7 @@ static THD_FUNCTION(can_tx, p) {
txmsg.data32[1] = 0x00FF00FF;
while (true) {
- canTransmit(&CAND1, CAN_ANY_MAILBOX, &txmsg, MS2ST(100));
+ canTransmit(&CAND1, CAN_ANY_MAILBOX, &txmsg, TIME_MS2I(100));
chThdSleepMilliseconds(500);
}
}