aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/STM32/STM32F0xx/UART
diff options
context:
space:
mode:
Diffstat (limited to 'testhal/STM32/STM32F0xx/UART')
-rw-r--r--testhal/STM32/STM32F0xx/UART/Makefile4
-rw-r--r--testhal/STM32/STM32F0xx/UART/main.c4
2 files changed, 4 insertions, 4 deletions
diff --git a/testhal/STM32/STM32F0xx/UART/Makefile b/testhal/STM32/STM32F0xx/UART/Makefile
index 5519eb0ba..6eefd756b 100644
--- a/testhal/STM32/STM32F0xx/UART/Makefile
+++ b/testhal/STM32/STM32F0xx/UART/Makefile
@@ -94,8 +94,8 @@ include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/port_v6m.mk
# Other files (optional).
#include $(CHIBIOS)/test/lib/test.mk
-include $(CHIBIOS)/test/rt/rt_test.mk
-include $(CHIBIOS)/test/oslib/oslib_test.mk
+#include $(CHIBIOS)/test/rt/rt_test.mk
+#include $(CHIBIOS)/test/oslib/oslib_test.mk
# Define linker script file here
LDSCRIPT= $(STARTUPLD)/STM32F051x8.ld
diff --git a/testhal/STM32/STM32F0xx/UART/main.c b/testhal/STM32/STM32F0xx/UART/main.c
index 08c60b9ad..d0777e637 100644
--- a/testhal/STM32/STM32F0xx/UART/main.c
+++ b/testhal/STM32/STM32F0xx/UART/main.c
@@ -53,7 +53,7 @@ static void txend2(UARTDriver *uartp) {
palClearPad(GPIOC, GPIOC_LED4);
chSysLockFromISR();
chVTResetI(&vt1);
- chVTSetI(&vt1, MS2ST(5000), restart, NULL);
+ chVTSetI(&vt1, TIME_MS2I(5000), restart, NULL);
chSysUnlockFromISR();
}
@@ -79,7 +79,7 @@ static void rxchar(UARTDriver *uartp, uint16_t c) {
palSetPad(GPIOC, GPIOC_LED4);
chSysLockFromISR();
chVTResetI(&vt2);
- chVTSetI(&vt2, MS2ST(200), ledoff, NULL);
+ chVTSetI(&vt2, TIME_MS2I(200), ledoff, NULL);
chSysUnlockFromISR();
}