aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/STM32/STM32F3xx/I2C-LSM303DLHC/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'testhal/STM32/STM32F3xx/I2C-LSM303DLHC/Makefile')
-rw-r--r--testhal/STM32/STM32F3xx/I2C-LSM303DLHC/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/testhal/STM32/STM32F3xx/I2C-LSM303DLHC/Makefile b/testhal/STM32/STM32F3xx/I2C-LSM303DLHC/Makefile
index 707dd7bd5..00d84bee6 100644
--- a/testhal/STM32/STM32F3xx/I2C-LSM303DLHC/Makefile
+++ b/testhal/STM32/STM32F3xx/I2C-LSM303DLHC/Makefile
@@ -71,7 +71,7 @@ endif
# Enables the use of FPU (no, softfp, hard).
ifeq ($(USE_FPU),)
- USE_FPU = hard
+ USE_FPU = no
endif
#
@@ -201,7 +201,8 @@ CPPWARN = -Wall -Wextra -Wundef
# List all user C define here, like -D_DEBUG=1
UDEFS = -DCHPRINTF_USE_FLOAT=1 -DSHELL_CMD_TEST_ENABLED=0 \
- -DLSM303DLHC_ACC_USE_ADVANCED=0 -DLSM303DLHC_COMP_USE_ADVANCED=0
+ -DLSM303DLHC_ACC_USE_ADVANCED=0 -DLSM303DLHC_COMP_USE_ADVANCED=0 \
+ -DLSM303DLHC_SHARED_I2C=0
# Define ASM defines here
UADEFS =