aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/STM32/STM32F3xx/UART
diff options
context:
space:
mode:
Diffstat (limited to 'testhal/STM32/STM32F3xx/UART')
-rw-r--r--testhal/STM32/STM32F3xx/UART/Makefile4
-rw-r--r--testhal/STM32/STM32F3xx/UART/main.c4
2 files changed, 4 insertions, 4 deletions
diff --git a/testhal/STM32/STM32F3xx/UART/Makefile b/testhal/STM32/STM32F3xx/UART/Makefile
index ed46ff28f..7acae2819 100644
--- a/testhal/STM32/STM32F3xx/UART/Makefile
+++ b/testhal/STM32/STM32F3xx/UART/Makefile
@@ -99,8 +99,8 @@ include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/port_v7m.mk
# Other files (optional).
#include $(CHIBIOS)/test/lib/test.mk
-include $(CHIBIOS)/test/rt/rt_test.mk
-include $(CHIBIOS)/test/oslib/oslib_test.mk
+#include $(CHIBIOS)/test/rt/rt_test.mk
+#include $(CHIBIOS)/test/oslib/oslib_test.mk
# Define linker script file here
LDSCRIPT= $(STARTUPLD)/STM32F303xC.ld
diff --git a/testhal/STM32/STM32F3xx/UART/main.c b/testhal/STM32/STM32F3xx/UART/main.c
index 1ef5bb6b9..cf88c2448 100644
--- a/testhal/STM32/STM32F3xx/UART/main.c
+++ b/testhal/STM32/STM32F3xx/UART/main.c
@@ -53,7 +53,7 @@ static void txend2(UARTDriver *uartp) {
palClearPad(GPIOE, GPIOE_LED3_RED);
chSysLockFromISR();
chVTResetI(&vt1);
- chVTSetI(&vt1, MS2ST(5000), restart, NULL);
+ chVTSetI(&vt1, TIME_MS2I(5000), restart, NULL);
chSysUnlockFromISR();
}
@@ -79,7 +79,7 @@ static void rxchar(UARTDriver *uartp, uint16_t c) {
palSetPad(GPIOE, GPIOE_LED3_RED);
chSysLockFromISR();
chVTResetI(&vt2);
- chVTSetI(&vt2, MS2ST(200), ledoff, NULL);
+ chVTSetI(&vt2, TIME_MS2I(200), ledoff, NULL);
chSysUnlockFromISR();
}