aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/STM32/STM32F4xx/RTC
diff options
context:
space:
mode:
Diffstat (limited to 'testhal/STM32/STM32F4xx/RTC')
-rw-r--r--testhal/STM32/STM32F4xx/RTC/Makefile12
-rw-r--r--testhal/STM32/STM32F4xx/RTC/main.c3
2 files changed, 9 insertions, 6 deletions
diff --git a/testhal/STM32/STM32F4xx/RTC/Makefile b/testhal/STM32/STM32F4xx/RTC/Makefile
index 6736dd39d..05ed107b3 100644
--- a/testhal/STM32/STM32F4xx/RTC/Makefile
+++ b/testhal/STM32/STM32F4xx/RTC/Makefile
@@ -99,6 +99,8 @@ include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/port_v7m.mk
# Other files (optional).
#include $(CHIBIOS)/test/rt/test.mk
+include $(CHIBIOS)/os/hal/lib/streams/streams.mk
+include $(CHIBIOS)/os/various/shell/shell.mk
# Define linker script file here
LDSCRIPT= $(STARTUPLD)/STM32F407xG.ld
@@ -113,11 +115,10 @@ CSRC = $(STARTUPSRC) \
$(PLATFORMSRC) \
$(BOARDSRC) \
$(TESTSRC) \
+ $(STREAMSSRC) \
+ $(SHELLSRC) \
$(CHIBIOS)/os/various/evtimer.c \
$(CHIBIOS)/os/various/syscalls.c \
- $(CHIBIOS)/os/various/shell.c \
- $(CHIBIOS)/os/hal/lib/streams/memstreams.c \
- $(CHIBIOS)/os/hal/lib/streams/chprintf.c \
main.c
# C++ sources that can be compiled in ARM or THUMB mode depending on the global
@@ -149,7 +150,8 @@ ASMSRC = $(STARTUPASM) $(PORTASM) $(OSALASM)
INCDIR = $(STARTUPINC) $(KERNINC) $(PORTINC) $(OSALINC) \
$(HALINC) $(PLATFORMINC) $(BOARDINC) $(TESTINC) \
- $(CHIBIOS)/os/hal/lib/streams $(CHIBIOS)/os/various
+ $(STREAMSINC) $(SHELLINC) \
+ $(CHIBIOS)/os/various
#
# Project, sources and paths
@@ -199,7 +201,7 @@ CPPWARN = -Wall -Wextra -Wundef
#
# List all user C define here, like -D_DEBUG=1
-UDEFS =
+UDEFS = -DSHELL_CMD_TEST_ENABLED=0
# Define ASM defines here
UADEFS =
diff --git a/testhal/STM32/STM32F4xx/RTC/main.c b/testhal/STM32/STM32F4xx/RTC/main.c
index 3c029028a..c4507af54 100644
--- a/testhal/STM32/STM32F4xx/RTC/main.c
+++ b/testhal/STM32/STM32F4xx/RTC/main.c
@@ -278,7 +278,8 @@ int main(void){
/* Shell initialization.*/
sdStart(&SD6, &ser_cfg);
shellInit();
- shellCreateStatic(&shell_cfg1, waShell, sizeof(waShell), NORMALPRIO);
+ chThdCreateStatic(waShell, sizeof(waShell), NORMALPRIO,
+ shellThread, (void *)&shell_cfg1);
/* wait until user do not want to test wakeup */
while (true){