aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/STM32/multi/USB_CDC
diff options
context:
space:
mode:
Diffstat (limited to 'testhal/STM32/multi/USB_CDC')
-rw-r--r--testhal/STM32/multi/USB_CDC/Makefile-stm32f303_discovery4
-rw-r--r--testhal/STM32/multi/USB_CDC/Makefile-stm32f407_discovery4
-rwxr-xr-xtesthal/STM32/multi/USB_CDC/Makefile-stm32f746_discovery4
-rw-r--r--testhal/STM32/multi/USB_CDC/Makefile-stm32l476_discovery4
4 files changed, 12 insertions, 4 deletions
diff --git a/testhal/STM32/multi/USB_CDC/Makefile-stm32f303_discovery b/testhal/STM32/multi/USB_CDC/Makefile-stm32f303_discovery
index 36b9e25ac..7f6036185 100644
--- a/testhal/STM32/multi/USB_CDC/Makefile-stm32f303_discovery
+++ b/testhal/STM32/multi/USB_CDC/Makefile-stm32f303_discovery
@@ -102,7 +102,9 @@ include $(CHIBIOS)/os/hal/osal/rt/osal.mk
include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/port_v7m.mk
# Other files (optional).
-include $(CHIBIOS)/test/rt/test.mk
+include $(CHIBIOS)/test/lib/test.mk
+include $(CHIBIOS)/test/rt/rt_test.mk
+include $(CHIBIOS)/test/oslib/oslib_test.mk
include $(CHIBIOS)/os/hal/lib/streams/streams.mk
include $(CHIBIOS)/os/various/shell/shell.mk
diff --git a/testhal/STM32/multi/USB_CDC/Makefile-stm32f407_discovery b/testhal/STM32/multi/USB_CDC/Makefile-stm32f407_discovery
index 17fce1f58..2f88e393d 100644
--- a/testhal/STM32/multi/USB_CDC/Makefile-stm32f407_discovery
+++ b/testhal/STM32/multi/USB_CDC/Makefile-stm32f407_discovery
@@ -102,7 +102,9 @@ include $(CHIBIOS)/os/hal/osal/rt/osal.mk
include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/port_v7m.mk
# Other files (optional).
-include $(CHIBIOS)/test/rt/test.mk
+include $(CHIBIOS)/test/lib/test.mk
+include $(CHIBIOS)/test/rt/rt_test.mk
+include $(CHIBIOS)/test/oslib/oslib_test.mk
include $(CHIBIOS)/os/hal/lib/streams/streams.mk
include $(CHIBIOS)/os/various/shell/shell.mk
diff --git a/testhal/STM32/multi/USB_CDC/Makefile-stm32f746_discovery b/testhal/STM32/multi/USB_CDC/Makefile-stm32f746_discovery
index 026b92789..4a35f6cbb 100755
--- a/testhal/STM32/multi/USB_CDC/Makefile-stm32f746_discovery
+++ b/testhal/STM32/multi/USB_CDC/Makefile-stm32f746_discovery
@@ -107,7 +107,9 @@ include $(CHIBIOS)/os/hal/osal/rt/osal.mk
include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/port_v7m.mk
# Other files (optional).
-include $(CHIBIOS)/test/rt/test.mk
+include $(CHIBIOS)/test/lib/test.mk
+include $(CHIBIOS)/test/rt/rt_test.mk
+include $(CHIBIOS)/test/oslib/oslib_test.mk
include $(CHIBIOS)/os/hal/lib/streams/streams.mk
include $(CHIBIOS)/os/various/shell/shell.mk
diff --git a/testhal/STM32/multi/USB_CDC/Makefile-stm32l476_discovery b/testhal/STM32/multi/USB_CDC/Makefile-stm32l476_discovery
index be9aff4a5..0eed16249 100644
--- a/testhal/STM32/multi/USB_CDC/Makefile-stm32l476_discovery
+++ b/testhal/STM32/multi/USB_CDC/Makefile-stm32l476_discovery
@@ -102,7 +102,9 @@ include $(CHIBIOS)/os/hal/osal/rt/osal.mk
include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/port_v7m.mk
# Other files (optional).
-include $(CHIBIOS)/test/rt/test.mk
+include $(CHIBIOS)/test/lib/test.mk
+include $(CHIBIOS)/test/rt/rt_test.mk
+include $(CHIBIOS)/test/oslib/oslib_test.mk
include $(CHIBIOS)/os/hal/lib/streams/streams.mk
include $(CHIBIOS)/os/various/shell/shell.mk