diff options
Diffstat (limited to 'testhal')
-rw-r--r-- | testhal/STM32/STM32L4xx/QSPI-N25Q128/Makefile | 4 | ||||
-rw-r--r-- | testhal/STM32/STM32L4xx/QSPI-N25Q128/halconf.h | 2 | ||||
-rw-r--r-- | testhal/STM32/STM32L4xx/QSPI-N25Q128/mcuconf.h | 2 |
3 files changed, 5 insertions, 3 deletions
diff --git a/testhal/STM32/STM32L4xx/QSPI-N25Q128/Makefile b/testhal/STM32/STM32L4xx/QSPI-N25Q128/Makefile index 7a8a46ee0..13da447eb 100644 --- a/testhal/STM32/STM32L4xx/QSPI-N25Q128/Makefile +++ b/testhal/STM32/STM32L4xx/QSPI-N25Q128/Makefile @@ -98,6 +98,7 @@ include $(CHIBIOS)/os/hal/osal/rt/osal.mk include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/port_v7m.mk
# Other files (optional).
+include $(CHIBIOS)/os/ex/Micron/m25q.mk
include $(CHIBIOS)/os/hal/lib/streams/streams.mk
# Define linker script file here
@@ -113,6 +114,7 @@ CSRC = $(STARTUPSRC) \ $(PLATFORMSRC) \
$(BOARDSRC) \
$(STREAMSSRC) \
+ $(M25QSRC) \
main.c
# C++ sources that can be compiled in ARM or THUMB mode depending on the global
@@ -145,7 +147,7 @@ ASMXSRC = $(STARTUPASM) $(PORTASM) $(OSALASM) INCDIR = $(CHIBIOS)/os/license \
$(STARTUPINC) $(KERNINC) $(PORTINC) $(OSALINC) \
- $(HALINC) $(PLATFORMINC) $(BOARDINC) \
+ $(HALINC) $(PLATFORMINC) $(BOARDINC) $(M25QINC) \
$(STREAMSINC) $(CHIBIOS)/os/various
#
diff --git a/testhal/STM32/STM32L4xx/QSPI-N25Q128/halconf.h b/testhal/STM32/STM32L4xx/QSPI-N25Q128/halconf.h index 5ab199774..0dcde8147 100644 --- a/testhal/STM32/STM32L4xx/QSPI-N25Q128/halconf.h +++ b/testhal/STM32/STM32L4xx/QSPI-N25Q128/halconf.h @@ -153,7 +153,7 @@ * @brief Enables the SPI subsystem.
*/
#if !defined(HAL_USE_SPI) || defined(__DOXYGEN__)
-#define HAL_USE_SPI TRUE
+#define HAL_USE_SPI FALSE
#endif
/**
diff --git a/testhal/STM32/STM32L4xx/QSPI-N25Q128/mcuconf.h b/testhal/STM32/STM32L4xx/QSPI-N25Q128/mcuconf.h index 4b99a9ce4..1422bc0b6 100644 --- a/testhal/STM32/STM32L4xx/QSPI-N25Q128/mcuconf.h +++ b/testhal/STM32/STM32L4xx/QSPI-N25Q128/mcuconf.h @@ -262,7 +262,7 @@ * SPI driver system settings.
*/
#define STM32_SPI_USE_SPI1 FALSE
-#define STM32_SPI_USE_SPI2 TRUE
+#define STM32_SPI_USE_SPI2 FALSE
#define STM32_SPI_USE_SPI3 FALSE
#define STM32_SPI_SPI1_RX_DMA_STREAM STM32_DMA_STREAM_ID(2, 3)
#define STM32_SPI_SPI1_TX_DMA_STREAM STM32_DMA_STREAM_ID(2, 4)
|