aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--keyboards/mechmini/config.h2
-rw-r--r--keyboards/mechmini/keymaps/default/keymap.c4
-rw-r--r--keyboards/mechmini/rules.mk2
-rw-r--r--keyboards/ps2avrGB/keymaps/mechmini/keymap.c28
4 files changed, 4 insertions, 32 deletions
diff --git a/keyboards/mechmini/config.h b/keyboards/mechmini/config.h
index b5c696f3f..ecd50ca29 100644
--- a/keyboards/mechmini/config.h
+++ b/keyboards/mechmini/config.h
@@ -23,7 +23,7 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
// TODO: share these strings with usbconfig.h
// Edit usbconfig.h to change these.
#define MANUFACTURER winkeyless.kr
-#define PRODUCT ps2avrGB
+#define PRODUCT mechmini
/* matrix size */
#define MATRIX_ROWS 8
diff --git a/keyboards/mechmini/keymaps/default/keymap.c b/keyboards/mechmini/keymaps/default/keymap.c
index 4b3ed916c..786132f7b 100644
--- a/keyboards/mechmini/keymaps/default/keymap.c
+++ b/keyboards/mechmini/keymaps/default/keymap.c
@@ -13,10 +13,10 @@ You should have received a copy of the GNU General Public License
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
-#include "ps2avrGB.h"
+#include "mechmini.h"
const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
- MECHMINI_KEYMAP(
+ KEYMAP(
TAB, Q, W, E, R, T, Y, U, I, O, P, BSLS,
LCTL, A, S, D, F, G, H, J, K, L, SCLN,
LSFT, Z, X, C, V, B, N, M, COMM, DOT, SLSH,
diff --git a/keyboards/mechmini/rules.mk b/keyboards/mechmini/rules.mk
index e2b5922ea..26dfe36d0 100644
--- a/keyboards/mechmini/rules.mk
+++ b/keyboards/mechmini/rules.mk
@@ -40,4 +40,4 @@ CUSTOM_MATRIX = yes
SRC = matrix.c
# programming options
-PROGRAM_CMD = ./keyboards/ps2avrGB/program $(TARGET).hex
+PROGRAM_CMD = ./keyboards/mechmini/program $(TARGET).hex
diff --git a/keyboards/ps2avrGB/keymaps/mechmini/keymap.c b/keyboards/ps2avrGB/keymaps/mechmini/keymap.c
deleted file mode 100644
index 4b3ed916c..000000000
--- a/keyboards/ps2avrGB/keymaps/mechmini/keymap.c
+++ /dev/null
@@ -1,28 +0,0 @@
-/*
-This program is free software: you can redistribute it and/or modify
-it under the terms of the GNU General Public License as published by
-the Free Software Foundation, either version 2 of the License, or
-(at your option) any later version.
-
-This program is distributed in the hope that it will be useful,
-but WITHOUT ANY WARRANTY; without even the implied warranty of
-MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-GNU General Public License for more details.
-
-You should have received a copy of the GNU General Public License
-along with this program. If not, see <http://www.gnu.org/licenses/>.
-*/
-
-#include "ps2avrGB.h"
-
-const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
- MECHMINI_KEYMAP(
- TAB, Q, W, E, R, T, Y, U, I, O, P, BSLS,
- LCTL, A, S, D, F, G, H, J, K, L, SCLN,
- LSFT, Z, X, C, V, B, N, M, COMM, DOT, SLSH,
- GRV, LALT, LGUI, SPC, ENT, RGUI, RALT, RCTL
- )
-};
-
-const uint16_t PROGMEM fn_actions[] = {
-};