aboutsummaryrefslogtreecommitdiffstats
path: root/docs/feature_userspace.md
diff options
context:
space:
mode:
Diffstat (limited to 'docs/feature_userspace.md')
-rw-r--r--docs/feature_userspace.md12
1 files changed, 2 insertions, 10 deletions
diff --git a/docs/feature_userspace.md b/docs/feature_userspace.md
index 1cc8ca742..e162d423c 100644
--- a/docs/feature_userspace.md
+++ b/docs/feature_userspace.md
@@ -211,15 +211,7 @@ bool process_record_user(uint16_t keycode, keyrecord_t *record) {
if ( (temp_mod | temp_osm) & MOD_MASK_SHIFT )
#endif
{ //
- #if defined(__arm__) // only run for ARM boards
- SEND_STRING(":dfu-util");
- #elif defined(BOOTLOADER_DFU) // only run for DFU boards
- SEND_STRING(":dfu");
- #elif defined(BOOTLOADER_HALFKAY) // only run for teensy boards
- SEND_STRING(":teensy");
- #elif defined(BOOTLOADER_CATERINA) // only run for Pro Micros
- SEND_STRING(":avrdude");
- #endif // bootloader options
+ SEND_STRING(":flash");
}
if ( (temp_mod | temp_osm) & MOD_MASK_CTRL) {
SEND_STRING(" -j8 --output-sync");
@@ -244,7 +236,7 @@ endif
This will add a new `KC_MAKE` keycode that can be used in any of your keymaps. And this keycode will output `make <keyboard>:<keymap>`, making frequent compiling easier. And this will work with any keyboard and any keymap as it will output the current boards info, so that you don't have to type this out every time.
-Also, holding `shift` will add the appropriate flashing command (`:dfu`, `:teensy`, `:avrdude`, `:dfu-util`) for a majority of keyboards. Holding `control` will add some commands that will speed up compiling time by processing multiple files at once.
+Also, holding Shift will add the flash target (`:flash`) to the command. Holding Control will add some commands that will speed up compiling time by processing multiple files at once.
And for the boards that lack a shift key, or that you want to always attempt the flashing part, you can add `FLASH_BOOTLOADER = yes` to the `rules.mk` of that keymap.