aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/bigseries/keymaps/leddance
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/bigseries/keymaps/leddance')
-rw-r--r--keyboards/bigseries/keymaps/leddance/config.h23
-rwxr-xr-xkeyboards/bigseries/keymaps/leddance/keymap.c127
-rw-r--r--keyboards/bigseries/keymaps/leddance/rules.mk1
3 files changed, 0 insertions, 151 deletions
diff --git a/keyboards/bigseries/keymaps/leddance/config.h b/keyboards/bigseries/keymaps/leddance/config.h
deleted file mode 100644
index 57398fb99..000000000
--- a/keyboards/bigseries/keymaps/leddance/config.h
+++ /dev/null
@@ -1,23 +0,0 @@
-/*
-Copyright 2018 Cole Markham
-
-This program is free software: you can redistribute it and/or modify
-it under the terms of the GNU General Public License as published by
-the Free Software Foundation, either version 2 of the License, or
-(at your option) any later version.
-
-This program is distributed in the hope that it will be useful,
-but WITHOUT ANY WARRANTY; without even the implied warranty of
-MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-GNU General Public License for more details.
-
-You should have received a copy of the GNU General Public License
-along with this program. If not, see <http://www.gnu.org/licenses/>.
-*/
-
-#ifndef CONFIG_USER_H
-#define CONFIG_USER_H
-
-#define TAPPING_TERM 400
-
-#endif
diff --git a/keyboards/bigseries/keymaps/leddance/keymap.c b/keyboards/bigseries/keymaps/leddance/keymap.c
deleted file mode 100755
index 3cd8f1db7..000000000
--- a/keyboards/bigseries/keymaps/leddance/keymap.c
+++ /dev/null
@@ -1,127 +0,0 @@
-/*
-Copyright 2018 Cole Markham
-
-This program is free software: you can redistribute it and/or modify
-it under the terms of the GNU General Public License as published by
-the Free Software Foundation, either version 2 of the License, or
-(at your option) any later version.
-
-This program is distributed in the hope that it will be useful,
-but WITHOUT ANY WARRANTY; without even the implied warranty of
-MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-GNU General Public License for more details.
-
-You should have received a copy of the GNU General Public License
-along with this program. If not, see <http://www.gnu.org/licenses/>.
-*/
-
-#include QMK_KEYBOARD_H
-
-
-extern rgblight_config_t rgblight_config;
-
-enum custom_keycodes {
- BL = SAFE_RANGE
-};
-
-enum custom_layers {
- BASE = 0,
- LED
-};
-
-//Tap Dance Declarations
-enum {
- TD_TOGGLE = 0
-};
-
-void dance_toggle (qk_tap_dance_state_t *state, void *user_data) {
- if (state->count >= 2) {
- println("Double tapped, switching layers");
- if (layer_state_is(LED)) {
- layer_off(LED);
- } else {
- layer_on(LED);
- }
- } else {
- print("Single tapped: ");
- if (layer_state_is(LED)) {
-#ifdef RGBLIGHT_ENABLE
- if (!rgblight_config.enable) {
- rgblight_enable();
- }
- rgblight_step();
-#endif
- } else {
- println("Base layer, sending string");
- SEND_STRING("This thing is BIG!!\n");
- }
- }
-}
-
-//Tap Dance Definitions
-qk_tap_dance_action_t tap_dance_actions[] = {
- [TD_TOGGLE] = ACTION_TAP_DANCE_FN(dance_toggle)
-// Other declarations would go here, separated by commas, if you have them
-};
-
-const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
-
-[BASE] = LAYOUT(
- TD(TD_TOGGLE)),
-[LED] = LAYOUT(
- TD(TD_TOGGLE)
- )
-
-
-};
-
-
-const macro_t *action_get_macro(keyrecord_t *record, uint8_t id, uint8_t opt) {
- return MACRO_NONE ;
-}
-
-
-void matrix_init_user(void) {
-}
-
-void matrix_scan_user(void) {
-}
-
-bool process_record_user(uint16_t keycode, keyrecord_t *record) {
- // Nothing here, see dance_toggle
- return true;
-}
-
-void led_set_user(uint8_t usb_led) {
-
- if (usb_led & (1 << USB_LED_NUM_LOCK)) {
-
- } else {
-
- }
-
- if (usb_led & (1 << USB_LED_CAPS_LOCK)) {
-
- } else {
-
- }
-
- if (usb_led & (1 << USB_LED_SCROLL_LOCK)) {
-
- } else {
-
- }
-
- if (usb_led & (1 << USB_LED_COMPOSE)) {
-
- } else {
-
- }
-
- if (usb_led & (1 << USB_LED_KANA)) {
-
- } else {
-
- }
-
-}
diff --git a/keyboards/bigseries/keymaps/leddance/rules.mk b/keyboards/bigseries/keymaps/leddance/rules.mk
deleted file mode 100644
index 1ba2fa8fb..000000000
--- a/keyboards/bigseries/keymaps/leddance/rules.mk
+++ /dev/null
@@ -1 +0,0 @@
-TAP_DANCE_ENABLE = yes \ No newline at end of file