aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/dztech/dz60rgb_ansi/v2/rules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/dztech/dz60rgb_ansi/v2/rules.mk')
-rw-r--r--keyboards/dztech/dz60rgb_ansi/v2/rules.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/keyboards/dztech/dz60rgb_ansi/v2/rules.mk b/keyboards/dztech/dz60rgb_ansi/v2/rules.mk
new file mode 100644
index 000000000..9dda31a1b
--- /dev/null
+++ b/keyboards/dztech/dz60rgb_ansi/v2/rules.mk
@@ -0,0 +1,23 @@
+MCU = atmega32u4
+
+# Bootloader selection
+# Teensy halfkay
+# Pro Micro caterina
+# Atmel DFU atmel-dfu
+# LUFA DFU lufa-dfu
+# QMK DFU qmk-dfu
+# ATmega32A bootloadHID
+# ATmega328P USBasp
+BOOTLOADER = atmel-dfu
+
+BACKLIGHT_ENABLE = no
+BOOTMAGIC_ENABLE = lite # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = yes # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = no # Console for debug
+COMMAND_ENABLE = no # Commands for debug and configuration
+#SLEEP_LED_ENABLE = yes # Breathing sleep LED during USB suspend
+NKRO_ENABLE = yes # USB Nkey Rollover
+AUDIO_ENABLE = no
+RGB_MATRIX_ENABLE = IS31FL3733 # Use RGB matrix
+NO_USB_STARTUP_CHECK = no # Disable initialization only when usb is plugged in