aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/infinity60/rules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/infinity60/rules.mk')
-rw-r--r--keyboards/infinity60/rules.mk36
1 files changed, 7 insertions, 29 deletions
diff --git a/keyboards/infinity60/rules.mk b/keyboards/infinity60/rules.mk
index f93766af9..579eab0f3 100644
--- a/keyboards/infinity60/rules.mk
+++ b/keyboards/infinity60/rules.mk
@@ -1,16 +1,5 @@
-# project specific files
-SRC = matrix.c \
- led.c \
- led_controller.c
-
-## chip/board settings
-# - the next two should match the directories in
-# <chibios>/os/hal/ports/$(MCU_FAMILY)/$(MCU_SERIES)
-# - For Teensies, FAMILY = KINETIS and SERIES is either
-# KL2x (LC) or K20x (3.0,3.1,3.2).
-# - For Infinity KB, SERIES = K20x
-MCU_FAMILY = KINETIS
-MCU_SERIES = K20x
+# MCU name
+MCU = MK20DX128
# Linker script to use
# - it should exist either in <chibios>/os/common/ports/ARMCMx/compilers/GCC/ld/
@@ -23,14 +12,6 @@ MCU_SERIES = K20x
# - MK20DX128BLDR4 for Infinity with Kiibohd bootloader
MCU_LDSCRIPT = MK20DX128BLDR4
-# Startup code to use
-# - it should exist in <chibios>/os/common/ports/ARMCMx/compilers/GCC/mk/
-# - STARTUP =
-# - kl2x for Teensy LC
-# - k20x5 for Teensy 3.0 and Infinity KB
-# - k20x7 for Teensy 3.1 and 3.2
-MCU_STARTUP = k20x5
-
# Board: it should exist either in <chibios>/os/hal/boards/
# or <this_dir>/boards
# - BOARD =
@@ -40,14 +21,6 @@ MCU_STARTUP = k20x5
# - MCHCK_K20 for Infinity KB
BOARD = MCHCK_K20
-# Cortex version
-# Teensy LC is cortex-m0; Teensy 3.x are cortex-m4
-MCU = cortex-m4
-
-# ARM version, CORTEX-M0/M1 are 6, CORTEX-M3/M4/M7 are 7
-# I.e. 6 for Teensy LC; 7 for Teensy 3.x
-ARMV = 7
-
# Vector table for application
# 0x00000000-0x00001000 area is occupied by bootlaoder.*/
# The CORTEX_VTOR... is needed only for MCHCK/Infinity KB
@@ -72,6 +45,11 @@ SLEEP_LED_ENABLE = yes # Breathing sleep LED during USB suspend
NKRO_ENABLE = yes # USB Nkey Rollover
CUSTOM_MATRIX = yes # Custom matrix file
+# project specific files
+SRC = matrix.c \
+ led.c \
+ led_controller.c
+
LAYOUTS = 60_ansi_split_bs_rshift