aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/matrix/noah/rules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/matrix/noah/rules.mk')
-rw-r--r--keyboards/matrix/noah/rules.mk29
1 files changed, 4 insertions, 25 deletions
diff --git a/keyboards/matrix/noah/rules.mk b/keyboards/matrix/noah/rules.mk
index 80854e67e..19e432d2a 100644
--- a/keyboards/matrix/noah/rules.mk
+++ b/keyboards/matrix/noah/rules.mk
@@ -1,38 +1,15 @@
-## chip/board settings
-# - the next two should match the directories in
-# <chibios>/os/hal/ports/$(MCU_FAMILY)/$(MCU_SERIES)
-MCU_FAMILY = STM32
-MCU_SERIES = STM32F4xx
+# MCU name
+MCU = STM32F411
# Linker script to use
# - it should exist either in <chibios>/os/common/ports/ARMCMx/compilers/GCC/ld/
# or <this_dir>/ld/
MCU_LDSCRIPT = noah_boot
-# Startup code to use
-# - it should exist in <chibios>/os/common/startup/ARMCMx/compilers/GCC/mk/
-MCU_STARTUP = stm32f4xx
-
# Board: it should exist either in <chibios>/os/hal/boards/
# or <this_dir>/boards
BOARD = noah_bd
-# Cortex version
-MCU = cortex-m4
-
-# ARM version, CORTEX-M0/M1 are 6, CORTEX-M3/M4/M7 are 7
-ARMV = 7
-
-USE_FPU = yes
-
-# Vector table for application
-# 0x00000000-0x00001000 area is occupied by bootlaoder.*/
-OPT_DEFS =
-
-# Options to pass to dfu-util when flashing
-#DFU_ARGS = -d 0483:df11 -a 0 -s 0x08000000:leave
-#DFU_SUFFIX_ARGS = -p DF11 -v 0483
-
# Build Options
# comment out to disable the options.
#
@@ -52,3 +29,5 @@ RGBLIGHT_CUSTOM_DRIVER = yes
CUSTOM_MATRIX = yes
# project specific files
SRC += ws2812.c matrix.c
+
+LAYOUTS = 65_iso_blocker