aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/model01/rules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/model01/rules.mk')
-rw-r--r--keyboards/model01/rules.mk35
1 files changed, 0 insertions, 35 deletions
diff --git a/keyboards/model01/rules.mk b/keyboards/model01/rules.mk
deleted file mode 100644
index 29c028ac8..000000000
--- a/keyboards/model01/rules.mk
+++ /dev/null
@@ -1,35 +0,0 @@
-# MCU name
-MCU = atmega32u4
-
-# Bootloader selection
-# Teensy halfkay
-# Pro Micro caterina
-# Atmel DFU atmel-dfu
-# LUFA DFU lufa-dfu
-# QMK DFU qmk-dfu
-# ATmega32A bootloadHID
-# ATmega328P USBasp
-BOOTLOADER = caterina
-
-# Build Options
-# change yes to no to disable
-#
-BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration
-MOUSEKEY_ENABLE = yes # Mouse keys
-EXTRAKEY_ENABLE = yes # Audio control and System control
-CONSOLE_ENABLE = yes # Console for debug
-COMMAND_ENABLE = no # Commands for debug and configuration
-# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
-SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
-# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
-NKRO_ENABLE = no # USB Nkey Rollover
-MIDI_ENABLE = no # MIDI support
-UNICODE_ENABLE = no # Unicode
-
-CUSTOM_MATRIX = yes
-QUANTUM_LIB_SRC += i2c_master.c
-SRC += leds.c \
- matrix.c
-
-# You can set RGB_MATRIX_ENABLE = no in your rules.mk to disable this and save the Flash
-RGB_MATRIX_ENABLE = custom # Enable RGB matrix effects.