aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/torn/rules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/torn/rules.mk')
-rw-r--r--keyboards/torn/rules.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/keyboards/torn/rules.mk b/keyboards/torn/rules.mk
new file mode 100644
index 000000000..caf544d13
--- /dev/null
+++ b/keyboards/torn/rules.mk
@@ -0,0 +1,27 @@
+# MCU name
+MCU = atmega328p
+
+# Bootloader selection
+BOOTLOADER = USBasp
+
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = no # Mouse keys
+EXTRAKEY_ENABLE = no # Audio control and System control
+CONSOLE_ENABLE = no # Console for debug
+COMMAND_ENABLE = no # Commands for debug and configuration
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = no # Enable keyboard RGB underglow
+ENCODER_ENABLE = yes # Enable rotary encoder
+OLED_DRIVER_ENABLE = yes
+CUSTOM_MATRIX = lite
+
+SRC += matrix.c \
+ mcp23018.c \
+ torn_encoder.c \
+ torn_oled.c
+QUANTUM_LIB_SRC += i2c_master.c