aboutsummaryrefslogtreecommitdiffstats
path: root/quantum/stm32/proton_c.mk
diff options
context:
space:
mode:
Diffstat (limited to 'quantum/stm32/proton_c.mk')
-rw-r--r--quantum/stm32/proton_c.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/quantum/stm32/proton_c.mk b/quantum/stm32/proton_c.mk
index a65e283d3..ff28a4cb5 100644
--- a/quantum/stm32/proton_c.mk
+++ b/quantum/stm32/proton_c.mk
@@ -2,8 +2,12 @@
# These are defaults based on what has been implemented for ARM boards
AUDIO_ENABLE = yes
-RGBLIGHT_ENABLE = no
-BACKLIGHT_ENABLE = no
+WS2812_DRIVER = bitbang
+
+# Force task driven PWM until ARM can provide automatic configuration
+ifneq ($(strip $(BACKLIGHT_ENABLE)), no)
+ BACKLIGHT_ENABLE = software
+endif
# The rest of these settings shouldn't change