aboutsummaryrefslogtreecommitdiffstats
path: root/users/bcat
diff options
context:
space:
mode:
Diffstat (limited to 'users/bcat')
-rw-r--r--users/bcat/bcat.c6
-rw-r--r--users/bcat/config.h18
-rw-r--r--users/bcat/rules.mk5
3 files changed, 11 insertions, 18 deletions
diff --git a/users/bcat/bcat.c b/users/bcat/bcat.c
new file mode 100644
index 000000000..bea64dbaa
--- /dev/null
+++ b/users/bcat/bcat.c
@@ -0,0 +1,6 @@
+#include "quantum.h"
+
+#if defined(RGBLIGHT_ENABLE)
+ /* Adjust RGB static hue ranges for shorter gradients than default. */
+ const uint8_t RGBLED_GRADIENT_RANGES[] PROGMEM = {255, 127, 63, 31, 15};
+#endif
diff --git a/users/bcat/config.h b/users/bcat/config.h
index 5f49a4ed3..f6be07bf6 100644
--- a/users/bcat/config.h
+++ b/users/bcat/config.h
@@ -65,21 +65,3 @@
#define MOUSEKEY_WHEEL_MAX_SPEED 3
#define MOUSEKEY_WHEEL_TIME_TO_MAX 150
#endif
-
-#if defined(KEYBOARD_cannonkeys_instant60)
- /*
- * Work around EEPROM incompatibility with VIA:
- * https://github.com/qmk/qmk_firmware/issues/6589#issuecomment-524042457.
- */
- #undef EEPROM_MAGIC_ADDR
- #undef EEPROM_VERSION_ADDR
- #undef DYNAMIC_KEYMAP_EEPROM_ADDR
- #undef EEPROM_CUSTOM_BACKLIGHT
- #undef DYNAMIC_KEYMAP_MACRO_EEPROM_ADDR
-
- #define EEPROM_MAGIC_ADDR 34
- #define EEPROM_VERSION_ADDR 36
- #define DYNAMIC_KEYMAP_EEPROM_ADDR 37
- #define EEPROM_CUSTOM_BACKLIGHT 637
- #define DYNAMIC_KEYMAP_MACRO_EEPROM_ADDR 638
-#endif
diff --git a/users/bcat/rules.mk b/users/bcat/rules.mk
index 107b470ed..6d3444b2c 100644
--- a/users/bcat/rules.mk
+++ b/users/bcat/rules.mk
@@ -1,3 +1,5 @@
+SRC += bcat.c
+
# Enable Bootmagic Lite to consistently reset to bootloader and clear EEPROM.
BOOTMAGIC_ENABLE = lite
@@ -16,3 +18,6 @@ SLEEP_LED_ENABLE = no
UCIS_ENABLE = no
UNICODE_ENABLE = no
UNICODEMAP_ENABLE = no
+
+# Enable link-time optimization to reduce binary size.
+LINK_TIME_OPTIMIZATION_ENABLE = yes