From 78a01068a46fb1ba969f3f7875ffc08a8acb6f15 Mon Sep 17 00:00:00 2001
From: Biacco42 <secondimpact_2000@yahoo.co.jp>
Date: Mon, 20 Aug 2018 04:52:23 +0900
Subject: Keymap: Remove needless lines / files for Ergo42 (#3685)

---
 keyboards/ergo42/keymaps/biacco-macOS/config.h        | 6 +-----
 keyboards/ergo42/keymaps/biacco-macOS/rules.mk        | 3 ---
 keyboards/ergo42/keymaps/biacco-underglow/config.h    | 6 +-----
 keyboards/ergo42/keymaps/biacco-underglow/rules.mk    | 4 ----
 keyboards/ergo42/keymaps/biacco/config.h              | 6 +-----
 keyboards/ergo42/keymaps/biacco/rules.mk              | 3 ---
 keyboards/ergo42/keymaps/default-illustrator/config.h | 6 +-----
 keyboards/ergo42/keymaps/default-illustrator/rules.mk | 3 ---
 keyboards/ergo42/keymaps/default-underglow/config.h   | 6 +-----
 keyboards/ergo42/keymaps/default/config.h             | 6 +-----
 keyboards/ergo42/keymaps/default/rules.mk             | 3 ---
 keyboards/ergo42/keymaps/hdbx/config.h                | 6 +-----
 keyboards/ergo42/keymaps/hdbx/rules.mk                | 5 -----
 keyboards/ergo42/keymaps/ichi-t/config.h              | 6 +-----
 14 files changed, 8 insertions(+), 61 deletions(-)
 delete mode 100644 keyboards/ergo42/keymaps/biacco-macOS/rules.mk
 delete mode 100644 keyboards/ergo42/keymaps/biacco/rules.mk
 delete mode 100644 keyboards/ergo42/keymaps/default-illustrator/rules.mk
 delete mode 100644 keyboards/ergo42/keymaps/default/rules.mk
 delete mode 100644 keyboards/ergo42/keymaps/hdbx/rules.mk

(limited to 'keyboards/ergo42/keymaps')

diff --git a/keyboards/ergo42/keymaps/biacco-macOS/config.h b/keyboards/ergo42/keymaps/biacco-macOS/config.h
index 5a6261c4f..360d6a562 100644
--- a/keyboards/ergo42/keymaps/biacco-macOS/config.h
+++ b/keyboards/ergo42/keymaps/biacco-macOS/config.h
@@ -18,10 +18,7 @@ You should have received a copy of the GNU General Public License
 along with this program.  If not, see <http://www.gnu.org/licenses/>.
 */
 
-#ifndef CONFIG_USER_H
-#define CONFIG_USER_H
-
-#include "../../config.h"
+#pragma once
 
 /* Use I2C or Serial, not both */
 
@@ -34,4 +31,3 @@ along with this program.  If not, see <http://www.gnu.org/licenses/>.
 // #define MASTER_RIGHT
 // #define EE_HANDS
 
-#endif
diff --git a/keyboards/ergo42/keymaps/biacco-macOS/rules.mk b/keyboards/ergo42/keymaps/biacco-macOS/rules.mk
deleted file mode 100644
index 457a3d01d..000000000
--- a/keyboards/ergo42/keymaps/biacco-macOS/rules.mk
+++ /dev/null
@@ -1,3 +0,0 @@
-ifndef QUANTUM_DIR
-	include ../../../../Makefile
-endif
diff --git a/keyboards/ergo42/keymaps/biacco-underglow/config.h b/keyboards/ergo42/keymaps/biacco-underglow/config.h
index bc80be306..efadfa814 100644
--- a/keyboards/ergo42/keymaps/biacco-underglow/config.h
+++ b/keyboards/ergo42/keymaps/biacco-underglow/config.h
@@ -18,10 +18,7 @@ You should have received a copy of the GNU General Public License
 along with this program.  If not, see <http://www.gnu.org/licenses/>.
 */
 
-#ifndef CONFIG_USER_H
-#define CONFIG_USER_H
-
-#include "../../config.h"
+#pragma once
 
 /* Use I2C or Serial, not both */
 
@@ -40,4 +37,3 @@ along with this program.  If not, see <http://www.gnu.org/licenses/>.
 #define RGBLIGHT_ANIMATIONS
 #define RGBLIGHT_SLEEP
 
-#endif
diff --git a/keyboards/ergo42/keymaps/biacco-underglow/rules.mk b/keyboards/ergo42/keymaps/biacco-underglow/rules.mk
index 75e9c6503..1e3cebb14 100644
--- a/keyboards/ergo42/keymaps/biacco-underglow/rules.mk
+++ b/keyboards/ergo42/keymaps/biacco-underglow/rules.mk
@@ -1,5 +1 @@
-ifndef QUANTUM_DIR
-	include ../../../../Makefile
-endif
-
 RGBLIGHT_ENABLE = yes
diff --git a/keyboards/ergo42/keymaps/biacco/config.h b/keyboards/ergo42/keymaps/biacco/config.h
index 5a6261c4f..360d6a562 100644
--- a/keyboards/ergo42/keymaps/biacco/config.h
+++ b/keyboards/ergo42/keymaps/biacco/config.h
@@ -18,10 +18,7 @@ You should have received a copy of the GNU General Public License
 along with this program.  If not, see <http://www.gnu.org/licenses/>.
 */
 
-#ifndef CONFIG_USER_H
-#define CONFIG_USER_H
-
-#include "../../config.h"
+#pragma once
 
 /* Use I2C or Serial, not both */
 
@@ -34,4 +31,3 @@ along with this program.  If not, see <http://www.gnu.org/licenses/>.
 // #define MASTER_RIGHT
 // #define EE_HANDS
 
-#endif
diff --git a/keyboards/ergo42/keymaps/biacco/rules.mk b/keyboards/ergo42/keymaps/biacco/rules.mk
deleted file mode 100644
index 457a3d01d..000000000
--- a/keyboards/ergo42/keymaps/biacco/rules.mk
+++ /dev/null
@@ -1,3 +0,0 @@
-ifndef QUANTUM_DIR
-	include ../../../../Makefile
-endif
diff --git a/keyboards/ergo42/keymaps/default-illustrator/config.h b/keyboards/ergo42/keymaps/default-illustrator/config.h
index 5a6261c4f..360d6a562 100644
--- a/keyboards/ergo42/keymaps/default-illustrator/config.h
+++ b/keyboards/ergo42/keymaps/default-illustrator/config.h
@@ -18,10 +18,7 @@ You should have received a copy of the GNU General Public License
 along with this program.  If not, see <http://www.gnu.org/licenses/>.
 */
 
-#ifndef CONFIG_USER_H
-#define CONFIG_USER_H
-
-#include "../../config.h"
+#pragma once
 
 /* Use I2C or Serial, not both */
 
@@ -34,4 +31,3 @@ along with this program.  If not, see <http://www.gnu.org/licenses/>.
 // #define MASTER_RIGHT
 // #define EE_HANDS
 
-#endif
diff --git a/keyboards/ergo42/keymaps/default-illustrator/rules.mk b/keyboards/ergo42/keymaps/default-illustrator/rules.mk
deleted file mode 100644
index 457a3d01d..000000000
--- a/keyboards/ergo42/keymaps/default-illustrator/rules.mk
+++ /dev/null
@@ -1,3 +0,0 @@
-ifndef QUANTUM_DIR
-	include ../../../../Makefile
-endif
diff --git a/keyboards/ergo42/keymaps/default-underglow/config.h b/keyboards/ergo42/keymaps/default-underglow/config.h
index bc80be306..efadfa814 100644
--- a/keyboards/ergo42/keymaps/default-underglow/config.h
+++ b/keyboards/ergo42/keymaps/default-underglow/config.h
@@ -18,10 +18,7 @@ You should have received a copy of the GNU General Public License
 along with this program.  If not, see <http://www.gnu.org/licenses/>.
 */
 
-#ifndef CONFIG_USER_H
-#define CONFIG_USER_H
-
-#include "../../config.h"
+#pragma once
 
 /* Use I2C or Serial, not both */
 
@@ -40,4 +37,3 @@ along with this program.  If not, see <http://www.gnu.org/licenses/>.
 #define RGBLIGHT_ANIMATIONS
 #define RGBLIGHT_SLEEP
 
-#endif
diff --git a/keyboards/ergo42/keymaps/default/config.h b/keyboards/ergo42/keymaps/default/config.h
index 5a6261c4f..360d6a562 100644
--- a/keyboards/ergo42/keymaps/default/config.h
+++ b/keyboards/ergo42/keymaps/default/config.h
@@ -18,10 +18,7 @@ You should have received a copy of the GNU General Public License
 along with this program.  If not, see <http://www.gnu.org/licenses/>.
 */
 
-#ifndef CONFIG_USER_H
-#define CONFIG_USER_H
-
-#include "../../config.h"
+#pragma once
 
 /* Use I2C or Serial, not both */
 
@@ -34,4 +31,3 @@ along with this program.  If not, see <http://www.gnu.org/licenses/>.
 // #define MASTER_RIGHT
 // #define EE_HANDS
 
-#endif
diff --git a/keyboards/ergo42/keymaps/default/rules.mk b/keyboards/ergo42/keymaps/default/rules.mk
deleted file mode 100644
index 457a3d01d..000000000
--- a/keyboards/ergo42/keymaps/default/rules.mk
+++ /dev/null
@@ -1,3 +0,0 @@
-ifndef QUANTUM_DIR
-	include ../../../../Makefile
-endif
diff --git a/keyboards/ergo42/keymaps/hdbx/config.h b/keyboards/ergo42/keymaps/hdbx/config.h
index 6bddef1ea..4f0704ae1 100644
--- a/keyboards/ergo42/keymaps/hdbx/config.h
+++ b/keyboards/ergo42/keymaps/hdbx/config.h
@@ -18,10 +18,7 @@ You should have received a copy of the GNU General Public License
 along with this program.  If not, see <http://www.gnu.org/licenses/>.
 */
 
-#ifndef CONFIG_USER_H
-#define CONFIG_USER_H
-
-#include "../../config.h"
+#pragma once
 
 /* Use I2C or Serial, not both */
 
@@ -44,4 +41,3 @@ along with this program.  If not, see <http://www.gnu.org/licenses/>.
 #define RGBLIGHT_SAT_STEP 17
 #define RGBLIGHT_VAL_STEP 17
 
-#endif
diff --git a/keyboards/ergo42/keymaps/hdbx/rules.mk b/keyboards/ergo42/keymaps/hdbx/rules.mk
deleted file mode 100644
index 1e5761278..000000000
--- a/keyboards/ergo42/keymaps/hdbx/rules.mk
+++ /dev/null
@@ -1,5 +0,0 @@
-RGBLIGHT_ENABLE = yes
-
-ifndef QUANTUM_DIR
-	include ../../../../Makefile
-endif
diff --git a/keyboards/ergo42/keymaps/ichi-t/config.h b/keyboards/ergo42/keymaps/ichi-t/config.h
index 5a6261c4f..360d6a562 100644
--- a/keyboards/ergo42/keymaps/ichi-t/config.h
+++ b/keyboards/ergo42/keymaps/ichi-t/config.h
@@ -18,10 +18,7 @@ You should have received a copy of the GNU General Public License
 along with this program.  If not, see <http://www.gnu.org/licenses/>.
 */
 
-#ifndef CONFIG_USER_H
-#define CONFIG_USER_H
-
-#include "../../config.h"
+#pragma once
 
 /* Use I2C or Serial, not both */
 
@@ -34,4 +31,3 @@ along with this program.  If not, see <http://www.gnu.org/licenses/>.
 // #define MASTER_RIGHT
 // #define EE_HANDS
 
-#endif
-- 
cgit v1.2.3