From 3650d59afe69484c7d8c489763e04ddd3d79c03b Mon Sep 17 00:00:00 2001
From: Akaash Suresh <casa.akaash@gmail.com>
Date: Thu, 2 Jan 2020 11:52:23 -0600
Subject: Merge upstream/master with userspace

---
 keyboards/lily58/keymaps/curry/config.h |  7 ++++
 keyboards/lily58/keymaps/curry/keymap.c | 71 +++++++++++++++++++++++++++++++++
 keyboards/lily58/keymaps/curry/rules.mk | 17 ++++++++
 3 files changed, 95 insertions(+)
 create mode 100644 keyboards/lily58/keymaps/curry/config.h
 create mode 100644 keyboards/lily58/keymaps/curry/keymap.c
 create mode 100644 keyboards/lily58/keymaps/curry/rules.mk

(limited to 'keyboards/lily58/keymaps')

diff --git a/keyboards/lily58/keymaps/curry/config.h b/keyboards/lily58/keymaps/curry/config.h
new file mode 100644
index 000000000..229213b3c
--- /dev/null
+++ b/keyboards/lily58/keymaps/curry/config.h
@@ -0,0 +1,7 @@
+#pragma once
+
+#define MASTER_LEFT
+#define USE_SERIAL_PD2
+
+#define OLED_DISABLE_TIMEOUT
+#define TAPPING_TERM_PER_KEY
diff --git a/keyboards/lily58/keymaps/curry/keymap.c b/keyboards/lily58/keymaps/curry/keymap.c
new file mode 100644
index 000000000..3e2e0ae49
--- /dev/null
+++ b/keyboards/lily58/keymaps/curry/keymap.c
@@ -0,0 +1,71 @@
+#include "curry.h"
+
+#define LAYOUT_lily58_base( \
+    K01, K02, K03, K04, K05, K06, K07, K08, K09, K0A, \
+    K11, K12, K13, K14, K15, K16, K17, K18, K19, K1A, \
+    K21, K22, K23, K24, K25, K26, K27, K28, K29, K2A,  \
+    K31, K32, K33, K34, K35, K36, K37, K38, K39, K3A  \
+  ) \
+  LAYOUT_wrapper( \
+    KC_ESC,  K01, K02, K03, K04, K05,                    K06, K07, K08, K09, K0A, KC_GRV, \
+    KC_TAB,  K11, K12, K13, K14, K15,                    K16, K17, K18, K19, K1A, KC_BSLS,  \
+    KC_LCTL, K21, K22, K23, K24, K25,                    K26, K27, K28, K29, K2A, KC_QUOT, \
+    OS_LSFT, K31, K32, K33, K34, K35, KC_LBRC, KC_RBRC,  K36, K37, K38, K39, K3A, OS_RSFT, \
+             OS_LGUI, OS_LALT, LOWER, KC_SPC,  KC_ENT,  RAISE, KC_BSPC, OS_RGUI \
+  )
+#define LAYOUT_lily58_base_wrapper(...) LAYOUT_lily58_base(__VA_ARGS__)
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+    [_QWERTY] = LAYOUT_lily58_base_wrapper(
+        ________________NUMBER_LEFT________________, ________________NUMBER_RIGHT_______________,
+        _________________QWERTY_L1_________________, _________________QWERTY_R1_________________,
+        _________________QWERTY_L2_________________, _________________QWERTY_R2_________________,
+        _________________QWERTY_L3_________________, _________________QWERTY_R3_________________
+    ),
+
+    [_COLEMAK] = LAYOUT_lily58_base_wrapper(
+        ________________NUMBER_LEFT________________, ________________NUMBER_RIGHT_______________,
+        _________________COLEMAK_L1________________, _________________COLEMAK_R1________________,
+        _________________COLEMAK_L2________________, _________________COLEMAK_R2________________,
+        _________________COLEMAK_L3________________, _________________COLEMAK_R3________________
+    ),
+
+    [_DVORAK] = LAYOUT_lily58_base_wrapper(
+        ________________NUMBER_LEFT________________, ________________NUMBER_RIGHT_______________,
+        _________________DVORAK_L1_________________, _________________DVORAK_R1_________________,
+        _________________DVORAK_L2_________________, _________________DVORAK_R2_________________,
+        _________________DVORAK_L3_________________, _________________DVORAK_R3_________________
+    ),
+
+    [_MODS] = LAYOUT_wrapper(
+        _______, ___________________BLANK___________________,                    ___________________BLANK___________________, _______,
+        _______, ___________________BLANK___________________,                    ___________________BLANK___________________, _______,
+        _______, ___________________BLANK___________________,                    ___________________BLANK___________________, _______,
+        KC_LSFT, ___________________BLANK___________________, _______,  _______, ___________________BLANK___________________, KC_RSFT,
+                                   _______, _______, _______, _______,  _______, _______, _______, _______
+    ),
+
+    [_LOWER] = LAYOUT_wrapper( \
+        _______, ___________________BLANK___________________,                    ___________________BLANK___________________, _______,
+        KC_F11,  _________________LOWER_L1__________________,                    _________________LOWER_R1__________________, KC_F12,
+        _______, _________________LOWER_L2__________________,                    _________________LOWER_R2__________________, _______,
+        _______, _________________LOWER_L3__________________, _______,  _______, _________________LOWER_R3__________________, _______,
+                                   _______, _______, _______, _______,  _______, _______, _______, _______
+    ),
+
+    [_RAISE] = LAYOUT_wrapper( \
+        _______, ___________________BLANK___________________,                    ___________________BLANK___________________, _______,
+        _______, _________________RAISE_L1__________________,                    _________________RAISE_R1__________________, _______,
+        _______, _________________RAISE_L2__________________,                    _________________RAISE_R2__________________, _______,
+        _______, _________________RAISE_L3__________________, _______,  _______, _________________RAISE_R3__________________, _______,
+                                   _______, _______, _______, _______,  _______, _______, _______, _______
+    ),
+
+    [_ADJUST] = LAYOUT_wrapper( \
+        _______, ___________________BLANK___________________,                    ___________________BLANK___________________, _______,
+        KC_MAKE, _________________ADJUST_L1_________________,                    _________________ADJUST_R1_________________, KC_RESET,
+        VRSN,    _________________ADJUST_L2_________________,                    _________________ADJUST_R2_________________, EEP_RST,
+        MG_NKRO, _________________ADJUST_L3_________________, _______,  _______, _________________ADJUST_R3_________________, RGB_IDL,
+                                   _______, _______, _______, _______,  _______, _______, _______, _______
+    ),
+};
diff --git a/keyboards/lily58/keymaps/curry/rules.mk b/keyboards/lily58/keymaps/curry/rules.mk
new file mode 100644
index 000000000..4e73f47f4
--- /dev/null
+++ b/keyboards/lily58/keymaps/curry/rules.mk
@@ -0,0 +1,17 @@
+BOOTMAGIC_ENABLE           	= no  # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE            	= no  # Mouse keys(+4700)
+EXTRAKEY_ENABLE            	= yes # Audio control and System control(+450)
+CONSOLE_ENABLE             	= no  # Console for debug(+400)
+COMMAND_ENABLE             	= no  # Commands for debug and configuration
+NKRO_ENABLE                	= yes # Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+BACKLIGHT_ENABLE           	= no  # Enable keyboard backlight functionality
+MIDI_ENABLE                	= no  # MIDI controls
+AUDIO_ENABLE               	= no  # Audio output on port C6
+UNICODE_ENABLE             	= no  # Unicode
+BLUETOOTH_ENABLE           	= no  # Enable Bluetooth with the Adafruit EZ-Key HID
+RGBLIGHT_ENABLE            	= no  # Enable WS2812 RGB underlight.
+SWAP_HANDS_ENABLE          	= no  # Enable one-hand typing
+TAP_DANCE_ENABLE 		   	= yes      # Enable Tap Dance.
+OLED_DRIVER_ENABLE 			= yes
+BOOTLOADER 					= atmel-dfu
+SPLIT_TRANSPORT 			= mirror
-- 
cgit v1.2.3