aboutsummaryrefslogtreecommitdiffstats
path: root/Bootloaders/DFU
diff options
context:
space:
mode:
authorDean Camera <dean@fourwalledcubicle.com>2013-01-10 21:09:53 +0000
committerDean Camera <dean@fourwalledcubicle.com>2013-01-10 21:09:53 +0000
commit5cdc29616ceed081e76de2439ed03a0e6c3a7dd1 (patch)
tree23be4f8f19d77bdeb67ec651c3a694ebebf87658 /Bootloaders/DFU
parentbdd74a5ed92e74657c18f37648b6e031d040f47a (diff)
downloadlufa-5cdc29616ceed081e76de2439ed03a0e6c3a7dd1.tar.gz
lufa-5cdc29616ceed081e76de2439ed03a0e6c3a7dd1.tar.bz2
lufa-5cdc29616ceed081e76de2439ed03a0e6c3a7dd1.zip
Update and add missing Atmel Studio project description XML files.
Diffstat (limited to 'Bootloaders/DFU')
-rw-r--r--Bootloaders/DFU/makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Bootloaders/DFU/makefile b/Bootloaders/DFU/makefile
index 9b26784e0..950e8b657 100644
--- a/Bootloaders/DFU/makefile
+++ b/Bootloaders/DFU/makefile
@@ -29,8 +29,8 @@ LD_FLAGS = -Wl,--section-start=.text=$(BOOT_START_OFFSET) $(BOOT_API_LD_FLAG
FLASH_SIZE_KB = 128
BOOT_SECTION_SIZE_KB = 8
-# Bootloader address calculation formulas (requires the "bc" unix utility)
-# Do not modify these macros, but rather modify the depedant values above.
+# Bootloader address calculation formulas
+# Do not modify these macros, but rather modify the dependent values above.
CALC_ADDRESS_IN_HEX = $(shell printf "0x%X" $$(( $(1) )) )
BOOT_START_OFFSET = $(call CALC_ADDRESS_IN_HEX, ($(FLASH_SIZE_KB) - $(BOOT_SECTION_SIZE_KB)) * 1024 )
BOOT_SEC_OFFSET = $(call CALC_ADDRESS_IN_HEX, ($(FLASH_SIZE_KB) * 1024) - $(strip $(1)) )
@@ -44,7 +44,7 @@ BOOT_API_LD_FLAGS += $(call BOOT_SECTION_LD_FLAG, signatures, Signatures, 8
# Default target
all:
-
+
# Include LUFA build script makefiles
include $(LUFA_PATH)/Build/lufa_core.mk
include $(LUFA_PATH)/Build/lufa_sources.mk