aboutsummaryrefslogtreecommitdiffstats
path: root/LUFA/Build/DMBS/Template
diff options
context:
space:
mode:
Diffstat (limited to 'LUFA/Build/DMBS/Template')
-rw-r--r--LUFA/Build/DMBS/Template/makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/LUFA/Build/DMBS/Template/makefile b/LUFA/Build/DMBS/Template/makefile
index ba60ab9c2..d88292388 100644
--- a/LUFA/Build/DMBS/Template/makefile
+++ b/LUFA/Build/DMBS/Template/makefile
@@ -20,18 +20,13 @@ LD_FLAGS =
# Default target
all:
-# Include LUFA-specific DMBS extension modules
-DMBS_LUFA_PATH ?= $(LUFA_PATH)/Build/LUFA
-include $(DMBS_LUFA_PATH)/lufa-sources.mk
-include $(DMBS_LUFA_PATH)/lufa-gcc.mk
-
-# Include common DMBS build system modules
-DMBS_PATH ?= $(LUFA_PATH)/Build/DMBS/DMBS
+# Include DMBS build script makefiles
+DMBS_PATH ?= ../DMBS
include $(DMBS_PATH)/core.mk
+include $(DMBS_PATH)/gcc.mk
include $(DMBS_PATH)/cppcheck.mk
include $(DMBS_PATH)/doxygen.mk
include $(DMBS_PATH)/dfu.mk
-include $(DMBS_PATH)/gcc.mk
include $(DMBS_PATH)/hid.mk
include $(DMBS_PATH)/avrdude.mk
include $(DMBS_PATH)/atprogram.mk