aboutsummaryrefslogtreecommitdiffstats
path: root/LUFA/makefile
diff options
context:
space:
mode:
Diffstat (limited to 'LUFA/makefile')
-rw-r--r--LUFA/makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/LUFA/makefile b/LUFA/makefile
index 73e760b90..ca5eacfe8 100644
--- a/LUFA/makefile
+++ b/LUFA/makefile
@@ -12,14 +12,17 @@
LUFA_VERSION_NUM := $(shell grep LUFA_VERSION_STRING Version.h | cut -d'"' -f2)
EXCLUDE_FROM_EXPORT := Documentation DoxygenPages CodeTemplates Build *.conf *.tar *.o *.d *.lss *.lst *.hex *.elf *.hex *.eep *.map *.bin
+# Default target - no default action when attempting to build the core directly
all:
+# Export the library core as a TAR archive for importing into an IDE
export_tar:
@echo Exporting LUFA library to a TAR archive...
@tar -cf LUFA_$(LUFA_VERSION_NUM).tar --directory=. $(EXCLUDE_FROM_EXPORT:%=--exclude=%) *
@tar -cf LUFA_$(LUFA_VERSION_NUM)_Code_Templates.tar CodeTemplates
@echo Export LUFA_$(LUFA_VERSION_NUM).tar complete.
+# Display the LUFA version of this library copy
version:
@echo "LUFA $(LUFA_VERSION_NUM)"
@@ -36,6 +39,7 @@ else
ARCH = {AVR8,UC3,XMEGA}
DOXYGEN_OVERRIDE_PARAMS = QUIET=YES PROJECT_NUMBER=$(LUFA_VERSION_NUM)
+ # Remove all object and associated files from the LUFA library core
clean:
rm -f $(LUFA_SRC_ALL_FILES:%.c=%.o)
rm -f $(LUFA_SRC_ALL_FILES:%.c=%.d)
@@ -46,5 +50,4 @@ else
include Build/lufa_doxygen.mk
endif
-
.PHONY: all export_tar version clean \ No newline at end of file